...

View Full Version : Trying to get my site working in firefox



Marc84
03-16-2005, 01:39 PM
Hello everybody
I'm trying to get my site working in firefox. My site is: http://www.beltonenplaza.com/ I've got the following problems:

- As you can see in firefox the website is centered left, but it should be in the middle. I've tried DIV { text-align: center; } but it doesn't work.

- The "Zoek!" button is placed totally left. It should be under the rest of the text.

- The text above the orange lines are placed in the bottom of the table. They should be in the middle. I've tried vertical-align: middle; but that doesn't work.

I hope you can help me with this.

Thanks.

evo
03-16-2005, 01:50 PM
For whatever is your outer table -- add: "margin: 0px auto" which will align the table to center.

As for the button, use padding-left, or margin-left to get it to where you want it to.

Or you could wrap it in a <div> which has margin: 0px auto in it.

ronaldb66
03-16-2005, 01:59 PM
The proper way to center-align a block level element like a div is to specify auto left and right margins; since the outer div seems to be the only one, this would set top and bottom margins to zero and left and right to auto:

margin: 0 auto;
Text-align should only apply to inline content; IE incorrectly applies this to block level elements as well.

You should really look into CSS a bit more; margins and padding go a long way in replacing junk like this:

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;


The text above the orange lines are placed in the bottom of the table.
What text above which orange lines? You mean the h2's? In IE everything shows up sort-of-alright, but it sure can be done a lot simpler; again, padding would go a long way into getting everything to line up nicely.


Looks like you've beaten me, evo... :o

Marc84
03-16-2005, 02:48 PM
Thanks, i got rid of all the &nbsp;'s, now i'm working on the rest.

Marc84
03-16-2005, 02:55 PM
I still can't get the website centered. I tried <div style=" margin: 0px auto"> but that didn't work. What did I do wrong?

EDIT: I've got it! I added this: padding: 0; width: 750px;

JamieR
03-16-2005, 03:03 PM
My advice is to get rid of ALL the tables and totally recode the layout using css for layout..
btw, whats with the huge number of <br /> tags? CSS is best used for that, if you want to apply a lot of breaks to a certain area.

Marc84
03-16-2005, 03:09 PM
Yeah i know. I'm trying to get rid of the <br />'s. I didn't make this layout myself.
If I delete all the <br />'s my site will look like this: http://www.beltonenplaza.com/index2.php Anybody got an idea how to solve this?

And i know i should get rid of all the tables and recode it completely with css. Anybody got some online readings about this?

Marc84
03-16-2005, 05:52 PM
Allright, I've fixed everything, thanks!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum