...

View Full Version : Favicon help



Hawtalta
02-14-2005, 06:36 AM
I searched the forums and put all the tags I thought should work in the site, but it doesn't seem to show any ideas?

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="icon" href="/favicon.ico" type="image/x-icon" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
<link rel="icon" href="/favicon.ico" type="image/x-icon" />

This is what I have. Site is www.hawtalta.com

_Aerospace_Eng_
02-14-2005, 07:04 AM
working fine for me, clear your cookies and temp files close your browser completely then go back to your site, should work then, o just like to add you are missing a doctype btw, looks as if it should be an xhtml doctype but then i see your coding and it isn't xhtml compliant, xhtml is all in lower case

Hawtalta
02-14-2005, 07:07 AM
How would I go about adding that? it is php with html. I just started this last month and am trying to teach myself everything. Thanks for the help.

_Aerospace_Eng_
02-14-2005, 07:52 AM
the doctype goes directly above the <html> tag check out this thread for more info http://www.codingforums.com/showthread.php?t=18346

J&J
02-15-2005, 07:10 PM
In the past, I couldn't make my favicon show, & I realized that certain browsers don't react the same way to relative URLs, the same thing happens with external styles.

To be safe, use an absolute URL in your favicon's location, like so:


<link rel="shortcut icon" href="http://www.yourdomain.com/favicon.ico" type="image/x-icon" />

Hawtalta
02-15-2005, 07:58 PM
It was workign, just needed to clear the cache.

J&J
02-15-2005, 08:04 PM
Er actually, it's not working/showing when viewed with Netscape 6.2.

Hawtalta
02-16-2005, 12:04 AM
Hmm wierd. I'll take a look when I get home.

rmedek
02-16-2005, 04:02 AM
I wish I could remember where I read this, but I'm pretty sure that favicons are pretty buggy to begin with; in other words, different browsers have radically different ways of caching them, displaying them, etc.

Not to stop you from using them, just saying that if you are sure you're doing everything right maybe it'll work itself out eventually... :)

_Aerospace_Eng_
02-16-2005, 04:11 AM
works for me in IE 6.02, FF 1.0, Netscape 7.02, and Opera 7.54



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum