View Full Version : DHTML menu scripts are not working, asking for ";" past the last line

02-02-2005, 10:06 PM
I am using two .js scripts to create a navigation menu throughout my site. Here is the menu info:

DHTML Menu version 3.3.19
* written by Andy Woolley
* Copyright 2002 Andy Woolley. All Rights Reserved.

There are two files with problems, menu_array.js and mmenu.js When the page loads, it loads w/ errors and the script debugger shows an expected ";" on the line PAST the last line of each script.

I am pretty familiar with ASP and HTML, but have never worked with javascript very much. I've seen code issues before that ask for a character on a line that doesn't exist, and it usually is a problem somewhere else on the page, but I'm lost here. The mmenu script is over 500 lines. I would paste some code for you all to view, but I'm not sure where to start.

the site is www.ntreak.com/index.asp

Thanks in advance!

evil kev
02-02-2005, 10:20 PM
hmm i think the problem has come from something outside of the javascript those error lines aren't javascript syntax i'm not sure how they ended up in your source code but i'd imagine its worth redownloading the script to see if they're still there they could be just added on to the end of the script which might mean you could just delete those lines, another option is that for some reason the server is adding the lines onto the end dynamically somehow but i dunno how that'd happen.

02-03-2005, 11:12 PM
fixed it, for some reason the scripts actually did need a semicolon on the last line. I had tried placing one after the last bit of code, but they needed to be on their own line. Interesting.