View Full Version : Problem displaying in Firefox...

01-22-2005, 07:25 AM
I'm not using external style sheets or anything, they're all written into the page, so that's not the problem... my journal is here: http://www.livejournal.com/users/misscookie It works perfectly in IE, but the main image doesn't show up in Firefox.

It's been suggested so far that:

1. I add a doctype to the page - It was already there, but I don't have the power to change it anyway because of the limits of using a journal service.

2. Use a CSS and HTML validator - I checked it out with W3C (http://validator.w3.org/), and the only error I can find that seems like it's the problem is the following:

Line 230, column 100: document type does not allow element "IMG" here; assuming missing "CAPTION" start-tag

<img src="http://www.geocities.com/xxvisualchaosxx/other/ljlayout-ss-main.jpg" class="x">
So my questions are... is it not displaying the image because of the particular place I set the code in the document, or could it be something else? And if it is, how do I fix it?

And by the way, I'm a bit of a newbie to programming and such, so you may have to explain things a little more than usual. Thanks in advance.

01-22-2005, 08:43 AM
It shows up just fine here (FF on Mac). Maybe it's just a bug?

01-22-2005, 08:47 AM
Nope, just figured it out a few minutes ago, actually! It was a problem with the z-index number... apparently if it's set at anything but positive, the image won't show up in Firefox. Thanks for trying it out though!