View Full Version : Problems with a COPY function...

12-17-2004, 06:53 PM
Hello all...
a few of your best here, gave me some real help here last week to get my javascript "copy" function built -- you know the type where you're filling in a form and there's a checkbox "Click here if shipping address is the same as the billing address..."

my problem is, that while it works fine on the first page, now it's not working at all, even tho I carefully copied the relevant parts of the code and copied same. in fact, when you click that little checkbox, nothing, nada, dicky-do-dingo happens!

is there a diff tween the two forms? well, yes, slight ones. first, the original was to allow a user to fill in info on a form to ship trucks from location A to B.
the new form allows the user to ship up to 6 trucks, so it's 6 times as long. to 'hide' those extra sections I'm using a small js code that lets you 'fold' the unused portions up and outta the way. the only other change is validation, where on the single page I use a link to an external js page and on the multiple form, the js is included.

I have attached the complete form below as a simple .txt file, and would much appreciate some guidance here....

the relevant js begins at line 56, and the checkbox onClick item is at line 466...and I've 'cut' the rest out...

if anyone could point me at a solution, that'd be swell!



12-18-2004, 06:07 PM
:confused: Errr.... I've just tested this on my computer and it works absolutely fine in both Firefox and IE 6.0. What are you testing it with? IE? Have you enabled JavaScript? As I said it works fine. I check the checkbox and it copies perfectly no worries.