...

View Full Version : background-attachment:fixed;



trib4lmaniac
09-27-2004, 09:49 PM
There must be a hack for this in IE somewhere. Even Netscape gets it right. (latest version.)

Demo of background-attachment:fixed @ http://www.meyerweb.com/eric/css/edge/complexspiral/demo.html

I'd give a link to my version, but i don't think http://localhost/ will do much for you :p

]|V|[agnus
09-27-2004, 10:21 PM
http://dean.edwards.name/IE7/

IE7 fixes that a whole lot more. Relies on scripting though. Perhaps somebody has compiled one of those nifty .htc thingies for this same feature though.

The demo you mentioned with IE7 enabled: http://dean.edwards.name/IE7/compatibility/complexspiral/demo.html

trib4lmaniac
09-27-2004, 10:34 PM
Bah, JS :mad:

Oh well. Im just not letting ie show it all :thumbsup:

]|V|[agnus
09-27-2004, 10:36 PM
What what kind of solution did you expect??

CSS hacks that make use of parsing bugs don't toggle functionality, they just hide or show certain blocks of code to different browsers.

IE simply doesn't have the support for this built INTO THE BROWSER. Only way to build on that is through scripting or those .htc files...

gohankid77
09-27-2004, 11:21 PM
Unfortunately, it isn't valid...

AaronW
09-27-2004, 11:42 PM
And I seem to recall it being a ~35kb .js file or something? Not too huge I guess, but would make for some weirdness while the js file loads.

gohankid77
09-27-2004, 11:49 PM
Has anybody else seen this article (http://www.neowin.net/comments.php?id=24366&category=main) at Neowin.net (http://www.neowin.net)?

That just sucks! I have to upgrade my OS just to code for IE (not to mention hardware)?

AaronW
09-27-2004, 11:57 PM
Don't develop for IE then. Develop with standards ;)

Hopefully people aren't actually upgrading their OSes to use the new IE6 SP2... I'd imagine they'd be smart enough to look for an IE alternative, like Firefox or Mozilla or Opera. Then again, anyone who spends $99 to upgrade their browser probably isn't the sharpest bulb in the basket.

gohankid77
09-28-2004, 12:21 AM
I won't start coding for IE again until I get the money to buy SP2 (or 64-Bit Edition) and the required hardware. I'm running WinME, and it is somewhat slow. I'm willing to bet that it would be a bit hard to use the same hardware in WinXP. ;)



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum