...

View Full Version : Flash corruption, make sense to you?



bradyj
06-22-2004, 10:44 PM
I am building a flash animation that uses photoshop alpha transparent files to make the look of 'rolling clouds'. Now, it plays beautiful on the stage and the first time I test it. But, after that, it becomes corrupt upon 'test movie' and 'publish'ing the file. Any ideas what I'm doing wrong here? I've never seen this before:
http://www.dotfive.com/stagegood.jpg
http://www.dotfive.com/testbad.jpg

mindlessLemming
06-23-2004, 03:47 AM
Hmmm... never seen that one before :(
Firsth thing I'd try would be bringing in the image as a transparent PNG and see if that lets you get away with anything...?

:o HTH.

bradyj
06-23-2004, 05:34 PM
Alright, I tried:
_quality = "BEST";

In the first frame, AND I tried changing to pngs, but not working.

I did figure out that when I put those alpha transparencies BENEATH the text, you don't get that corruption. When I put one cloud layer above the text, you get the corruption.

The corruption does not happen to regular bitmaps or vector graphics, it only happens to vector/bitmap graphics that are symbols. What a bunch of crap :mad: I'm gonna have to call macromedia and work around this one...

bradyj
06-23-2004, 06:04 PM
I was using the pngs in their bitmap state, since it didn't require any symbol techniques. When you put an alpha png on top of another symbol, it must be turned into a symbol for all the alpha transparency to interact properly.

So, by making the top layer of clouds a graphic symbol instead of a bitmap, no more corruption between elements. I can breath :cool:

P.S. -- Didn't clean up the HTML yet, but here's a link http://www.dotfive.com/clouds.html

No preloader, no optimization, so that 1.5mb may take a minute:)



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum