View Full Version : Newbie just installed php...

03-25-2004, 12:10 AM
I am having problems with my php installation:

I set up a copy of php-nuke on my laptop for educational purposes. Just for my use and training.

I installed mysql, followed the nuke.sql instructions, created my database, etc....and thought everything is fine.

After I edited my config.php file and pointed my browser to the admin file, the page is chock full of undefined variables, constants, etc errors. The nuke page is there just thrown all off-kilter due to these messages. I can log in as super admin, etc, and go to different pages, but something is WAY wrong. Most of the errors refer to the mainfile.php...

Now, first am I correct in thinking that since I am using Windows XP Professional's Personal Web setup that I DONT need the Apache server installed? That is probably something I am doing wrong....but what else am I doing wrong?

The errors specifically refer to things like: sitename, nukeurl, slogan, startdate, etc. I recognize all of this of course, but don't know why I am having errors.

I used SQLyog to create my nuke database...so why are there problems with these variables?

Can anyone out there help me?

03-25-2004, 09:23 AM
You probably have your errorreporting in anale-mode.


to turn it at a looser-mode

There is a big difference between notices/warnings/.../fatal errors.
The examplepages you use are probably written in a 'poor' codingstyle.

03-25-2004, 04:51 PM
Thank you thank you! That did it...I'm in business now. I appreciate your help and patience.


03-25-2004, 06:59 PM
You're welcome! Glad you got it running now :thumbsup: