View Full Version : CSS body{} not working in NS - still! Another self-pitying cry for help!

03-09-2004, 12:36 PM
I'm sorry, I still haven't achieved a positive effect, despite numerous changearounds of stylesheet links and stylesheets (http://www.testpage.memoriesforyou.co.uk/ccc.css).

I'm now finding more bugs occuring every time I even touch the code, so I'm trying to leave it alone, but the background is still missing, and the text is still defaulting to serif despite the fact that both are still valid css as far as I can see. If this goes on, I'm going to have to take a step backwards and unvalidate it, sprinkling my html with presentational tags. This would be bad, because I'm trying to sell myself as a standards-compliant designer - can anyone help??? Please? Before I become a sellout? Just take a look at the testpage (http://www.testpage.memoriesforyou.co.uk/index.htm) and let me know if you can see where I've gone wrong?

03-09-2004, 12:38 PM
It works fine in IE, just not in Netscape (even NS7.1). I live in fear of trying to sell my services to someone who's reading through NS and laughing at me.


03-09-2004, 01:47 PM
Hi there Gabrielle,

Your problem is caused by the comment in the css file.
It should be commented like this...

/*Memories For You and all content including documents,
pictures and stylesheets copyright 2004 to G Adnitt,

This should set you back on course :D


03-09-2004, 02:25 PM
I'm so chuffed! Thanks - I've spent about 12 hours going cross-eyed staring at the pc, and I didn't see the absolutely obvious:thumbsup:! You're brilliant, thanks!

03-09-2004, 02:51 PM
Gosh, Gabrielle,

you're making me blush profusely :o :o :o :o


03-09-2004, 07:29 PM
The thanks are still there, but I'll tone them down if you want. I just felt so stupid!