...

View Full Version : win2k SP4 + .net 1.0 server affects Javascript!?



brothercake
03-01-2004, 06:09 AM
I've got this client who uses my menu at http://www.udm4.com/ but he said that after upgrading his server to Win2K SP4 + .net 1.0 with IE6 SP1, the script no longer works on any page served by that machine.

If it was IE6 SP1 on that machine in which the script doesn't work, that might make some kind of sense. But how can the server environment affect the execution of scripts in another browser on a different machine?

Makes no sense. Can anyone shed any light on this? :confused:

fredmv
03-01-2004, 06:38 AM
I completely agree. That does make no sense whatsoever. Though, the question really is that is the client absolutely sure this is the problem? Perhaps it's really something else that's being overlooked? Maybe they didn't include one of the external JavaScript source files? Edited the code for the worse? Just trying to provide other possible reasons as to why it isn't working here.

Though, then again, even if this is the case it seems very unlikely because as you said, it seems almost instantly after upgrading (or in this case, downgrading) his server it started acting odd.

Of course, a quick (and free, mind you) solution would be to throw Linux on that machine… ;)

allida77
03-01-2004, 05:50 PM
If he is running asp.net pages then the asp.net account needs permissions to all folders used on the site. Does the menu not do anything at all? I would get him to stick a debug js file with a alert('foo') in whatever directory the js files are in to see if it is a permissions or pathing problem.

I have about the same set up at home and have no problems running your menu.

fredmv
03-09-2004, 06:38 AM
Ever figure this one out James? :D



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum