View Full Version : Problem formatting href on image with CSS

02-27-2004, 11:19 PM
Okay, I'm sure someone out there will see my mistake here very quickly, but for the life of me I can't figure out why I can't get my href colors (around images) to change to white. I'm using DW MX2004, if that matters.

I want the "1" border around my images (hrefs only) to be white wheter they have been visited, active, hover, etc...

I just can't seem to get it to work.

The link is: http://www.zilay.com/house/houseindex.htm

Some functionality may not be there yet, as I'm working on migrating my site from FrontPage to DW MX2004.

Any help is appreciated!


02-28-2004, 01:31 AM
"The operation timed out when trying to connect to zilay.com"
Your server's down.

Anyway, this should do it. Put it in your style sheet or thbe head of your doc. between <style></style> tags.

a img {border:1px solid #fff;

03-01-2004, 07:57 PM
Much appreciated response, mindlesslemming. I do have another question though. While that line of code updated my HREF images, it did not fix the link HREF - which still appears blue and underlined. I want this text to appear white, but yellow when on hover - and white again after being visited.

Is there some other location I'm setting these parameters and overlooking it?

Any help is appreciated.



03-01-2004, 08:10 PM
More CSS:
a:link { color: #fff }
a:visited { color: #fff }
a:hover { color: #ff0 }
a:active { color: #ff0 }

03-01-2004, 08:24 PM
Tried it, still isn't working. It must be getting this information from somewhere else?

I have even gone so far as to set these parameters within the "page properties" in MX2004. It still appears to get overwritten!

Any more ideas?

03-01-2004, 09:18 PM
Ooops, my mistake.

I forgot a closing } in my css.

Looks good now!

Thanks all...