...

View Full Version : Flash MX 2004 components problem



nadi
02-27-2004, 03:23 AM
Hi all,

I've created sort of quiz, very simple one, using components: radio buttons, checkboxes and text field.

Simple html page contains <object> with this swf. And all these live on some drive on Intranet.

Now the problem. When I open htm page everything is fine. But when other people open the same page, some of them can't see any of the components, just empty space instead, other see text fields instead of radio buttons and checkboxes.

I can't see any reason for such a behaviour. IE configuration? Flash player version on peoples PSs?

Of cause only I have Flash installed on my PS, nobody else. But all users have IE 6.0 for sure.

Any idea?

Thank you.

nadi
02-27-2004, 04:08 AM
This is an addition to the previous post.

Well, I found some users who, just as myself, do not have problem to see all the components properly.

So obviously it's not about Flash installed.

mindlessLemming
02-27-2004, 09:57 AM
A: Make sure everyone has the Flash Player (http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash) installed. Also make sure that when you're exporting the .swf from Flash that you set it to export at the lowest common denominator; if everyone is running really old systems, make sure to export the .swf for version 5 Flash player.

B: Make sure there are copies of all your components to your project's library before you export the file to .swf

If you can absolutely guarantee that both these requirements have been met, then I have no idea:confused:

All the best,
Andrew.

*edit: missed an important bit...:o

nadi
02-29-2004, 10:36 PM
Thank you, Andrew. I discovered my mistake - I published swf for version Flash Player 7 but foolishly haven't checked version detection. So users with the older versions were cut off without any notification.

But I'm confused with your "if everyone is running really old systems, make sure to export the .swf for version 5 Flash player.
". Would components driven by ActionScript 2.0 work under Flash Player 5?

Thanks.

mindlessLemming
03-01-2004, 03:29 AM
No. ActionScript 2 came out with Flash MX2004 (or maybe just MX?)
Either way, you need version 7 of the player for it to work.

nadi
03-01-2004, 03:36 AM
Ya, that's what I thought. Thanks Andrew.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum