View Full Version : display: block on <a> in <td>s behaving odd in IE

02-24-2004, 07:29 PM

Note the subnav on the left. Block level <a>s within <td>s. Straightforward, right? Behaves exactly as it should in Mozilla/FireFox.. IE, all versions, doesn't call the :hover pseudo-class unless you mouse over the text, but it still swaps the background across the whole cell, indicating that the <a>s are in fact block.

Here's the kicker: IE does this ONLY for the second two, NOT the first option!


Anybody know what's goin' on? Beuler? Beuler?

Paul Jr
02-25-2004, 06:24 AM
Works fine for me -- IE 6.

But why are you using images for a simple text color/background color switch? :confused:

02-25-2004, 07:50 AM
it's my coworker's project actually. i asked him the same thing. he was concerned about web safe colors, but correct me if i'm wrong, but even if you use an image, web safe colors have partly to do with system palettes and monitor depths as well, right? or not necessarily the latter.

it's seemed to me at this point thought that about any color goes for simple backgrounds like that. i've looked at different browsers on different systems and not really seen any significant differences these days.

02-25-2004, 07:56 AM
also, it works fine now because he just made them block level <a>s inside one master <div> instead of individual <td>s.. doesn't make much sense, but whatever, right?

02-25-2004, 09:47 AM
Any documentation I found about web safe colours says about the same thing.
If you're not designing for 640x480, you don't need to design for web-safe colours either. Probably stick within the 16-bit pallette though. (Not that I ever do :o )