...

View Full Version : bottom margin 0 not working in firebird



nick_a
02-10-2004, 07:58 PM
Sorry if this has been answered before, I searched but with no luck. Anyway I want my table to render all the way to the bottom of the page. I did this using a 100% table height and a bottommargin="0". It renders to the bottom in IE but not in firebird. Annyone know how I can fix this?
Here is the code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Liquid Systems Inc.</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
<!--
a {color:#666666; text-decoration:none}
a:hover {color:#EB8D1C; text-decoration:underlined}
body {SCROLLBAR-FACE-COLOR:#C4C4C4;
SCROLLBAR-HIGHLIGHT-COLOR:#D3D2D2; SCROLLBAR-SHADOW-COLOR:#666666;
SCROLLBAR-3DLIGHT-COLOR:#C4C4C4; SCROLLBAR-ARROW-COLOR:#506A78;
SCROLLBAR-TRACK-COLOR:#C4C4C4; SCROLLBAR-DARKSHADOW-COLOR:#C4C4C4;}
-->
</style>
</head>

<body bgcolor="#C4C4C4" topmargin="0" bottommargin="0">
<div align="center">
<table width="494" height="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td width="16" rowspan="3" valign="top" background="images/left_border.jpg">&nbsp;</td>
<td width="462" height="128" valign="top" bgcolor="#FFFFFF"><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="460" height="210" hspace="1" align="absmiddle">
<param name="movie" value="main.swf">
<param name="quality" value="high">
<embed src="main.swf" width="460" height="210" hspace="1" align="absmiddle" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed></object></td>
<td width="16" rowspan="3" valign="top" background="images/right_border.jpg">&nbsp;</td>
</tr>
<tr>
<td height="269" valign="top" bgcolor="#FFFFFF"> <iframe name="content" src="news.htm" height="350" width="448" scrolling="auto" frameborder="0">
</iframe> </td>
</tr>
<tr>
<td align="center" valign="bottom" bgcolor="#FFFFFF"><font color="#898989" size="1" face="Verdana, Arial, Helvetica, sans-serif"><a href="news.htm" target="content">news</a>
| <a href="about.htm" target="content">about</a> | <a href="services.htm" target="content">services</a> | <a href="contact.htm" target="content">contact</a>
| <a href="legal.htm" target="content">legal information</a></font></td>
</tr>
</table>
</div>
</body>
</html>

Thanks in advance.

coothead
02-10-2004, 09:21 PM
hi there nick_a,

Try adding this to your style sheet...

div{ height:100% }

c:D:Dthead

nick_a
02-11-2004, 11:57 PM
Im using tables though?... Im a little confused. I can post a jpeg of what is happening if needed. Thanks

Alex Vincent
02-12-2004, 03:14 AM
Is it working in Mozilla App Suite? Remember, Firefox (yes, they changed the name again) 0.8 is "not ready for production use".

If Mozilla shows the same bug, then tools like DOM Inspector can help you see what's going on.

nick_a
02-12-2004, 04:32 AM
hmm.. I dont have mozilla. Ill download it and test it out. If I have the same problem Ill reply.
thanks.

nick_a
02-12-2004, 04:33 AM
Originally posted by nick_a
hmm.. I dont have mozilla, I assumed that they would have the same core browser rendering characteristics. I guess thats why you dont assume. Ill download it and test it out. If I have the same problem Ill reply.
thanks.

nick_a
02-12-2004, 04:34 AM
oops hit quote instead of edit... sorry

coothead
02-12-2004, 04:53 AM
Hi there nick_a,

Im using tables though?... Im a little confused. I can post a jpeg of what is happening if needed. Thanks
Yes, but your table is contained within a div :D
Adding this to your style sheet...

div{ height:100% }

...renders the page as you require in....
IE6.0, Firefox 0.8, Netscape 7.0, Mozilla 1.5 and Opera 7.0

c:D:Dthead

nick_a
02-12-2004, 11:29 PM
ooohhh yea.... thanks a bunch.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum