...

View Full Version : iframe background difficulty



bazz
01-13-2004, 05:02 PM
I use an iframe in a dynamically generated page. If I use the same background as the page, it looks a bit messy where the edge of the iframe meets the background of the page. I have tried for the iframe, background : transparent; but it doesnt work. IIRC it shows up white.

I presently have the background in the iframe (which is an htm page), set to be the same as the main htm page.

see it here (http://www.ireland-info.com/cgi-bin/introduction.pl?dpt=marlfield_dpt) (below the big image)

any tips to have a consistent background throughout the whole htm page.

here's hoping

mindlessLemming
01-14-2004, 12:29 AM
You could try assigning an initial position of 0,0 to the I-frame BG...
This would then align it to the viewport (same as main BG)
Although I think that assigning a starting point invokes no-repeat aswell, but hopefully not (why the hell would it?).

Have a read of Eric Meyer's article (http://www.meyerweb.com/eric/css/edge/complexspiral/demo.html) , Your answer is in there somewhere.

P.S. Your site has come along way since you first posted it, but the padding in the header isn't even above and below the text/images.
Oh, and personally I would ditch the tiled BG img all together, way too 1996

ArcticFox
01-14-2004, 06:28 AM
Try adjusting the position of the background in your iframe using css.

I had the same problem:
http://arctic.ithium.net

All the iframes on my site had to have the BG positioned pixel-by-pixel until it all matched up; a REAL pain, but it works.

bazz
01-20-2004, 02:57 PM
so 1996? :D Plain gren of a similar shade then?

I'll read the article soon. Thanks both.:thumbsup:



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum