...

View Full Version : need help with personal web manager



lejon
12-11-2003, 11:52 AM
i installed iis, but i'm getting the page 'not available' after trying to look at http://localhost. i have win2k pro, and opened the personal web manager and can't figure out why iis isn't working.

Boberto
12-11-2003, 11:46 PM
Are you logged on as an administrator. I had that problem when I installed IIS on a computer at college, but when I logged on as an administrator it worked fine.

You may also have permissions problems. To fix it, go to My Computer >> inetpubb >> and right click on the wwwroot folder. Now click on directory security (I think that's what it's called) and change the settings on the users so that they can read the directory.

Hope this helps. :D

lejon
12-12-2003, 08:33 AM
i signed on as administrator and it still didn't work. when i right click on the file it doesn't show an option for permissions, it just looks like any other file. did i do something wrong? i thought installing iis would be easy. I can't do anything in asp now.

glenngv
12-12-2003, 09:48 AM
Is the IIS started properly and the Default Web Site running? If you have other webserver in you, check that they are not using the same default port 80.

lejon
12-12-2003, 11:28 AM
i don't think it started properly because i don't know how to start it. if you mean http://localhost as the default web site then no that is not running. i don't know how to do another webserver, or how to make it in port 80, so no on that too. here is a picture i'm getting from my personal web manager. see how there isn't a home page default. i don't know how to set that. would that be the problem?

Roelf
12-12-2003, 12:16 PM
sorry to offend you, but can you read? The screenshot says webpublishing is on, your homepage is not available because default document is off. surfing to http://localhost will not work because the server doesn't know which page to show. Set a default document (probably in advanced settings) or specify the page you want to view in the browser, like http://localhost/thepage.asp

success

lejon
12-12-2003, 12:51 PM
i know that in the advanced section it read plain and simple default document here: .... but that is the first thing i did. i put in the http://localhost/myfolder/myfile.asp and nothing happened. it won't set the default document for some reason.

i thought i would just install iis, make a subroot for for wwwroot in inetpub, and walaah the thing would work. is there an on button that i overlooked? this can't possibly be this difficult.

Roelf
12-12-2003, 02:30 PM
can you make a screenshot of the advances tab and show it here?

lejon
12-12-2003, 11:16 PM
here it is

Roelf
12-12-2003, 11:33 PM
i dont know this personal webmanager tool very well, but as far as i can tell, for your site, you created a subfolder for the IISSamples folder. So the url for your page is http://localhost/iissamples/jjweb/jtest.asp

in the default document(s) textbox, you should only mention the document itself, not the complete path (url) it should be like default.asp; default.htm; index.asp etc. (dont know i the semicolon is the correct separator, but taking the tour will probably tell you that.

The easiest way of making a website from a directory is right click in windows explorer on the folder icon, select the sharing thingy, select the tab "Web sharing" then click share this folder, give it some sensible name then go to your browser and request a page in this folder like http://localhost/foldername/pagename.asp

Succes

lejon
12-14-2003, 02:20 AM
i think my problem is that iis isn't running. how do i start it? i never got the iis symbol anywhere to start it from.

Roelf
12-14-2003, 09:02 PM
after installing IIS, it starts automatically, check in the services (right click my computer > manage > services) it is the world wide web publishing service ou are looking for

lejon
12-15-2003, 03:48 AM
yeah i checked that, it's set to automatic. i think that it may be due to norton. or due to the hundreds of worthless programs on my hard drive. i'm reinstalling windows 2k then installing iis from the get go. see if that helps. the iis wouldn't start under the restart options in the internet servics manager, and i'm assuming that is the last option i could take. hopefully it'll work now.

Mhtml
12-15-2003, 02:36 PM
I pretty much skipped all the reading cos I'm off to bed now, when I was using ASP (oh so long ago :)) my PWS would work but for some reason I could never navigate to http://localhost/ however, http://127.0.0.1 always worked.

Perhaps that is your problem.
I could never figure out why it never worked though, and I spent days on trying to fix it.

lejon
12-15-2003, 03:58 PM
i got it to work! finally! i formatted my computer with ntfs and then loaded iis first. localhost finally works. whew!... thanks for all the help. now i'm off to reload all my junk.

i knew it couldn't be that difficult. i did the same thing as before loading it from add components, but now localhost pops up just fine. i still wonder what the problem was.

lejon
12-16-2003, 08:18 AM
ok now it doesn't work. i must have the worst luck in the world. is iis really unstable? i have no clue what it is, i just need it for asp junk. all i have done since it last worked is installed my video/audio/and wireless card, and a bunch of windows updates sp1/sp4/directx9 etc. could it be the microsofts windows updates that make my iis quit? i'm about to throw my computer out the window.

Roelf
12-16-2003, 08:42 AM
did you rename your computer? did the tcp/ip settings change?

glenngv
12-16-2003, 08:56 AM
Open the Event Viewer to see if there are any IIS-related error log entries

lejon
12-16-2003, 09:38 AM
this is weird. i went back to windows update site and it showed that i hadn't installed anything, but the install history showed that i did. i reinstalled sp1, and internet explorer sp4, and now the dumb thing works. does stuff like this happen often?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum