...

View Full Version : a href not clickable?



operapixie
01-23-2013, 09:30 PM
Hi there,
I'm assuming this is a CSS or HTML issue, though I concede that I could well be wrong.

This (http://dev.yourbusybee.com/kaleco2/) WordPress homepage has a sidebar with two circles in the sidebar. Both have links within them, but for some reason neither is clickable (though I've added the hands to the hover effect). I'm not sure why. I've tried playing with the z-index, but haven't had any luck. Perhaps it has to do with the :before border effect? I don't know.

Also, the same mouseoever effect on these 2 circles next to the slideshow used to be in effect on the two circle images below the slideshow ("About" and "Events"), but it's not happening any more. I'm a little puzzled as to when that happened.

Thanks in advance.

~Laura

VIPStephan
01-23-2013, 09:49 PM
Yeah, it’s the :before style overlapping the anchor because it’s positioned absolutely while the anchor is “auto” (which is “static”). You need to assign position: relative and a z-index higher than the one of the generated content (“2” should suffice) to the anchor.

operapixie
01-23-2013, 09:59 PM
Ahhhhh...thank you awfully much. It seems as if I may need to either eliminate the :before altogether or figure out a way to create some invisible content for it. I suspected the little trick there might get me in a bit of trouble.

~Laura

VIPStephan
01-23-2013, 10:05 PM
No, why? You don’t need to remove the generated content. As I said, just apply position: relative; and z-index: 2 to the link inside that circle/box.

operapixie
01-23-2013, 10:50 PM
Oops, I missed the anchor part of the instructions. Sorry 'bout that. Ok. Working on getting that back to where it was.

operapixie
01-23-2013, 10:59 PM
Thank you thank you! That certainly solved it!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum