...

View Full Version : Browser not supported message



JeffJeffz
11-10-2012, 09:23 AM
Hello
Can anyone give me advice for a code to display on my website old browsers not supported.

Thanks
Jeff

coothead
11-10-2012, 10:17 AM
Hi there JeffJeffz,

and a warm welcome to these forums. ;)

If you are just referring to IE, then something like this would suffice...



<!--[if lt IE 8]>
<p>your browser is not supported</p>
<![endif]-->
coothead

Excavator
11-10-2012, 04:38 PM
Hello JeffJeffz,
Here is a little lengthier message:

in the markup -

<!--[if lt IE 7]>
<div id="ie6Warning">
<h2>Time to upgrade your browser?</h2>
<p>
If you're reading this, you're surfing using Internet Explorer 6, a 10+ year-old browser that
cannot cope with the demands of the modern internet. For the best web experience, it is strongly recommended
you upgrade to a more modern version of any of the browsers listed here:
<ol>
<li><a href="http://www.getfirefox.com/">Firefox</a></li>
<li><a href="http://www.opera.com/">Opera</a></li>
<li><a href="http://www.apple.com/safari/">Safari</a></li>
<li><a href="http://www.google.com/chrome">Google Chrome</a></li>
<li>or a more recent version of <a href="http://www.microsoft.com/windows/downloads/ie/getitnow.mspx">Internet Explorer</a></li>
</ol>
The layout of this site is designed to work with those browsers. We are reasonably certain that even if the layout is not quite
right in older browsers, the funcionality should still be available to you. Our suggestion of upgrading your browser is only for
your viewing pleasure and is by no means a requirement for using this website.
</p>
</div>
<![endif]-->


and styled from the CSS -
#ie6Warning {
width: 500px;
background: #fc6;
color: #999;
}

JeffJeffz
11-11-2012, 08:05 AM
Thanks Excavator worked perfect
googled a lot and could not find a decent script.


Hello JeffJeffz,
Here is a little lengthier message:

in the markup -

<!--[if lt IE 7]>
<div id="ie6Warning">
<h2>Time to upgrade your browser?</h2>
<p>
If you're reading this, you're surfing using Internet Explorer 6, a 10+ year-old browser that
cannot cope with the demands of the modern internet. For the best web experience, it is strongly recommended
you upgrade to a more modern version of any of the browsers listed here:
<ol>
<li><a href="http://www.getfirefox.com/">Firefox</a></li>
<li><a href="http://www.opera.com/">Opera</a></li>
<li><a href="http://www.apple.com/safari/">Safari</a></li>
<li><a href="http://www.google.com/chrome">Google Chrome</a></li>
<li>or a more recent version of <a href="http://www.microsoft.com/windows/downloads/ie/getitnow.mspx">Internet Explorer</a></li>
</ol>
The layout of this site is designed to work with those browsers. We are reasonably certain that even if the layout is not quite
right in older browsers, the funcionality should still be available to you. Our suggestion of upgrading your browser is only for
your viewing pleasure and is by no means a requirement for using this website.
</p>
</div>
<![endif]-->


and styled from the CSS -
#ie6Warning {
width: 500px;
background: #fc6;
color: #999;
}

JeffJeffz
11-11-2012, 08:07 AM
Worked Perfect Excavator



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum