...

View Full Version : Help me with IIS Installation



Nan Zhong
10-20-2003, 09:43 PM
Help me please!

Ok, I've installed IIS 5.1 from my windows xp pro cd, the last time I installed it was b4 I reformatted my computer... It worked fine then:rolleyes: But now whenever I try to acces my server by typing http://localhost in my browser it gives me this error:mad::

The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

--------------------------------------------------------------------------------

Please try the following:

Open the localhost home page, and then look for links to the information you want.
Click the Refresh button, or try again later.

Click Search to look for information on the Internet.
You can also see a list of related sites.




HTTP 500 - Internal server error
Internet Explorer

--------------------------------------------------------------------------------

Help Is VERY Appreciated!!:thumbsup:

raf
10-20-2003, 09:57 PM
Is IIS running ?

Did you recreate the websites virtual directories ?

Nan Zhong
10-20-2003, 10:04 PM
Well, what do you mean by open?
And I did not recreate the directories because shouldn't it just get to the default start page? I believe it is called iisstart.asp or something like that.

raf
10-20-2003, 10:25 PM
Open?

IIS must be running before it can serve any pages. So check your services (settings-->configurations-->system management --> services) and see if IIS is running.

You should get a default help-page or so, unless you removed the files or din't include them when you installed windows ...

Nan Zhong
10-20-2003, 10:37 PM
Ok, under services it says: Name: IIS Admin
Description: Allows administration of...
Status: Started
Startup Type: Automatic
Log On As: Local System

raf
10-20-2003, 10:43 PM
Create a new site.
(settings-->configurations-->system management --> internet information server --> rightclik on default-websites -->new virtual directory) Then just run through the wizard and choose a siename (say 'test') and browse to directory with a html file or so in it.

After completing the wizard. Open a browserwindow and type in
http://localhost/test/filename.htm

Nan Zhong
10-20-2003, 10:59 PM
Ok, I did just as you've told but it gives me the same error message...

oracleguy
10-21-2003, 12:58 AM
If you are using IE, goto tools > options > advanced > browsing > and uncheck show friendly HTTP errors

That may shed more light on your problem...

Nan Zhong
10-21-2003, 02:21 AM
Ok, I tried your suggestion but now I get basically the same error:

Server Error
The following error occurred:
Bad URL


--------------------------------------------------------------------------------
Please contact the administrator.

Help please...:confused: I really want to get this server working!

Nan Zhong
10-22-2003, 01:32 AM
Ok, I've decided that re-installing IIS for the fourth time may help. Just to make sure that I don't *accidentally* make a mistake could someone please give me a very precise list of steps to follow.:thumbsup:

Nan Zhong
10-23-2003, 06:52 PM
This may shed some light on those of you helping me.
When I unplugg my network cable, which is the cable containing my internet connection, IIS works fine. Both html and asp pages work. Once the cable is plugged and I have internet, IIS gives that error...


PLZZZ HELP!:confused:

surfie
11-04-2003, 06:43 AM
I wish I could get up to the your stage:rolleyes:

I can't even install IIS. It like freezes every single time at the end when it is "Completing configuration of SMTP server". Exactly how long does it take to install? And if you disabled any services via > services.msc, do I have to enable certain ones to install IIS?:(

Nan Zhong
11-04-2003, 09:22 PM
It takes like 10 minutes for me, and I'm pretty sure that once IIS is installed for you it will automatically restart all services it requires.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum