View Full Version : not found php file on server

10-18-2012, 11:15 AM
hey everybody ,today i found some problem on my server
i login in net2ftp and upload my php script on my own domain
it upload on it but when i see this file below error is occur on my domain
i upload a.php on server


echo "test";
and i see the a.php link
www.example.com/a.php i found this server error

Server Error

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

so, what do i do?
all html file are work on it why it not work for php
Anybody Explain me ,Thanks by minkoko :D

10-18-2012, 01:12 PM
You uploaded to the wrong place or your host doesn't support PHP. Try a phphinfo() or ask your host.

10-19-2012, 01:43 AM
Uh.. Have you tried looking in your file index? Why not try and create the file directly on the server. There might be FTP restrictions on script files, or something.

10-20-2012, 04:45 AM
ok ,now i fix my problem
my web had on one file name web.cofnig

<?xml version="1.0" encoding="UTF-8"?>
<httpRedirect enabled="false" destination="" exactDestination="false" childOnly="false" httpResponseStatus="Temporary" />
<directoryBrowse enabled="false" />
<defaultDocument enabled="true">
<clear />
<add value="default.html" />
<add value="default.htm" />
<add value="default.asp" />
<add value="default.aspx" />
<add value="index.htm" />
<add value="index.html" />
<add value="index.cfm" />
<add value="index.asp" />
<add value="index.aspx" />
<add value="index.php" />
<add value="awstats.pl" />
<add name="CGI Script Map" path="*.cgi" verb="5,GET,HEAD,POST" modules="CgiModule" scriptProcessor="\bin\perl.exe &quot;%s&quot; %s" resourceType="File" />
<add name="Perl Script Map" path="*.pl" verb="5,GET,HEAD,POST" modules="CgiModule" scriptProcessor="\bin\perl.exe &quot;%s&quot; %s" resourceType="File" />
<add name="PHP" path="*.php" verb="*" modules="CgiModule" scriptProcessor="" resourceType="Unspecified" />

and i remove this file now working my site but
i found some problem at google
when i search my site on google.com
Site is Under Construction
why it problem?