View Full Version : Problem with banner displaying

08-14-2012, 01:16 AM

Please can someone take a look at this page and tell me why the top banner disappears after a few seconds? I have tried to increase the z index on the 3.png code (<img src="3.png" style="height:168px;width:100%;z-index:30">) but it makes no difference how high I go it still disappears, it's almost as if it'[s being hidden by the background. The banner I plan to use will be almost transparent but I just made it blue for now to make it more noticeable.


Would be grateful of any help;)

Thanks in advance


08-14-2012, 04:01 AM
The fact that with IE it appears for a second and then disappears
tells me that it's because of <table>. With IE, a <table> has to load
before it appears ... that creates a delay.

So, this line is suspicious:
<div id="ctrdiv" style="position:absolute; top:0; padding: 0px; height:100%; width: 1003px">

Remove the position property and see what happens.

Don't use <table> anyhow ... not a good thing for layouts.

08-14-2012, 06:19 PM

Well I didn't manually add that line, the software adds in when you add a html object to the page, anyway I tried removing the position property but it made no difference (so I put it back).

The full background and the banner work independently of each other great, but there is a conflict when using them together.

Any other ideas?

08-14-2012, 09:36 PM
I guess I don't have an answer, sorry.

IMHO the effect you're going for is too much work,
too much time wasted, and nobody cares that
the background resizes. With web page content
for the reader to see, why would the background
make any difference? And how browser compatible
will this be?

Look at how much time you've spent on this so far,
and you don't even have any content yet.