...

View Full Version : Background Image not appearing?



enhancedigital
08-06-2012, 03:38 PM
Hello,

I am having an issue with a background image on one of my pages, and it's driving me nuts!

The page in question is here: http://enhancedigital.co.uk/seo.html

I have developed this page using notepad++, and when I have been testing the pages on my local machine with Firefox, the background image has been displaying correctly. However, when I uploaded the page via FTP and visited the site, the image would not show up.

Any ideas would be greatly appreciated!

Thanks

AndrewGSW
08-06-2012, 03:45 PM
http://enhancedigital.co.uk/images/seoBG.jpg - file not found.

You need to come back up a level (relative to the css file):


background-image:url("../images/seoBG.jpg");

Added: Actually the first link looks correct, so maybe you just haven't uploaded the image.

enhancedigital
08-06-2012, 04:06 PM
Wow, thanks for replying so quickly!

Could you explain in a little more detail? I'm pretty useless when it comes to this kind of stuff!

I have the seoBG.jpg image saved in the images folder, as with all other images. I have tried several different filenames in the CSS e.g.

background-image:url(images/seoBG.jpg);
background-image:url(./images/seoBG.jpg);
background-image:url(../images/seoBG.jpg);

...and the same again with the directories surrounded by ' and ", but no luck. All other images are displaying correctly so far.

Thanks!

AndrewGSW
08-06-2012, 05:05 PM
Perhaps just upload the file via FTP again. Try clearing your browser cache.

Is the file extension .jpg correct..

enhancedigital
08-06-2012, 05:13 PM
I have found the issue, the image saved in images folder was correct, but the filename was all lower case (seobg.jpg). In the CSS, the filename was seoBG.jpg.

I renamed the image file and it now appears correctly. I had no idea that was taken into account, lesson learnt!

Thanks for helping!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum