...

View Full Version : jQuery:reveal plugin - odd issue



WolfShade
07-03-2012, 01:42 PM
Hello, everyone.

I am working on a project that uses jQuery Reveal (plugin by Zurb) for modal windows. As seems to be the case many times, it works flawlessly in FireFox, but it has an issue in IE7 and IE8 (don't have IE9, but I'll just assume that the issue exists for it, too.)

Unfortunately, the dev system that I am working on is on another network that does not have internet access, so I cannot post code or provide a link. All I can do is give as much information as I can and hope that someone has experienced this issue, before, and knows a solution.

The page(s) in question all have navigation links that are anchor tags with a class that uses a 1x1 pixel image for a background on the "selected" navigation; the rest are transparent and show the background image of the body. When a link to open a Reveal modal is clicked, every navigation link loses transparency and does not get it back unless the page is refreshed/reloaded. (The modal still works as desired.)

I am pretty sure it has something to do with opacity that is being set in the Reveal code, but can't figure out how to get it to stop affecting the nav links. Any suggestions?

UPDATE: I just noticed that the "selected" nav is using a background color to indicate that it's selected, and the rest are using a 1x1 .png file with 100% opacity as the transparent background.

Thanks,

WolfShade
07-03-2012, 09:07 PM
Has anyone worked with the jQuery Reveal plugin?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum