...

View Full Version : IE 9 only formatting issues



zulux
06-01-2012, 11:53 PM
Greetings all,

I have a site that looks good on all browsers except IE 9. It looks good on chrome, opera, firefox, etc. It even looks good in IE 8 and 7. But with IE 9 divs are shifted and the page is broken. Try the following URL in IE 9 and you'll see that the right container is shifted to the bottom.

http://www.doc4uninsured.org/?location=Baltimore,MD&keywords=Chase-Brexton-Mt.-Vernon-Center-Dental

Try the same URL on other browsers and it should be OK. I"m using jquery in inject html into dom.

Anyone have any idea why it looks bad on IE 9? Thank you in advance for any input.

COBOLdinosaur
06-02-2012, 05:35 PM
E 9 is in quirksmode. Use a strict doctype like

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

or

<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta content="IE=edge,chrome=1" />

No offense, but IMO that is a very low quality page. It is the kind of site I visit once and then block. It is bloated, excessively
scripted, and far too agressive with browser resources. I suspect it crashes and hangs the browsers of a lot of users who are on
slow connections or older underpowered machines.

SB65
06-02-2012, 09:09 PM
I have to confess I read the previous post and thought "Well, it can't really be that bad, can it...?".

The validator brings up 9797 errors (http://validator.w3.org/check?uri=https%3A%2F%2Fwww.doctorsforuninsured.org%2F%3Flocation%3DBaltimore%2CMD%26keywords%3DChas e-Brexton-Mt.-Vernon-Center-Dental&charset=%28detect+automatically%29&doctype=Inline&group=0). Be warned, the validator page takes a long time to load.

I doubt very much whether just changing the doctype will make much difference. IE is in quirksmode (can't check in IE myself because it crashes) because of some of those many errors, I'm afraid.

Sorry....

zulux
06-03-2012, 12:06 AM
Solved. One of my affiliates had a simple html form in the page and, as the result, the page was broken in IE 9. I removed the form and it's fixed. How and why...only a higher power knows

Thanks all!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum