...

View Full Version : Problems displaying font using @font-face



gardman
05-28-2012, 01:32 PM
Hello,

I am having real difficultly displaying fonts correctly on IE 9 using @font-face.

Here is the CSS code I am using:

@font-face {
font-family: 'Ampersand';
src: url('../fonts/ampersand.eot');
src: local('?'), url('../fonts/ampersand.woff') format('woff'), url('../fonts/ampersand.ttf') format('truetype'), url('../fonts/ampersand.svg') format('svg');
font-weight: normal;
font-style: normal;
}

@font-face {
font-family: 'Gothamblack';
src: url('../fonts/gothamblack.eot');
src: local('?'), url('../fonts/gothamblack.woff') format('woff'), url('../fonts/gothamblack.ttf') format('truetype'), url('../fonts/gothamblack.svg') format('svg');
font-weight: normal;
font-style: normal;
}

The Ampersand font seems to work fine, but I cannot get the Gothamblack font to work on at all on IE, despite it working fine on other browsers. I have uploaded both fonts in the different formats to a 'fonts' folder on the server the site is being hosted on and have called the fonts using the 'font-family' tag within my CSS.

Please help!!!

VIPStephan
05-28-2012, 03:48 PM
[Ö] I cannot get the Gothamblack font to work on at all on IE, despite it working fine on other browsers.

Iím pretty sure that you are not allowed to embed Gotham at all with CSSís font-face method. Read Hoefler & Frere-Jonesí EULA (http://www.typography.com/home/eula.php), especially points 3.1, 3.2, and 3.3.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum