View Full Version : Jump to anchor tag in a frame - Netscape problems

07-24-2002, 08:14 PM
I have a Flash interface with links to HTML pages. The HTML pages have frames. Each Flash link, when clicked, is supposed to jump to a specific anchor tag in one of the frames.
I've got it working in IE but in Netscape 4.79 and in Netscape 6.2 I'm having problems.
You can observe this here:
As you can see, the anchor tags represent chapter sections: 1.1, 1.2, 1.3, etc. The first few sections seem to work fine, but once you're past, say, .4 Netscape just doesn't go there anymore. I've noticed that the page is never fully loaded. Why? I don't know. But I think that's why it won't jump to that section/anchor tag because it hasn't loaded yet.

Here is my ActionScript.

getURL ("javascript: openWin('" + chapter_file + "', '" + jump_to + "');void(0);");

I'm passing to a Javascript function which chapter page (HTML page with frames) to open and which anchor tag to jump to.
Here is my Javascript.

function changeFrame(url, which_win) {
which_win.mainFrame.location.href = url;

function update(which_win) {
changeFrame(jump_to, which_win);
function openWin(frameset, anchorlink) {
jump_to = anchorlink;
eq_window = window.open(frameset, 'eq_window');
myTimeout = setTimeout("update(eq_window);", 2000);

I'm already playing it safe and setting a timeOut so that the update function will definitely get called, even if it takes several tries. What can I do to make sure the page has fully loaded before I tell it to jump to the anchor tag, or just to make sure that Netscape understands the anchor tags, period?