...

View Full Version : Information from HTML form being stripped out of the email on Submit



coetzerl
02-22-2012, 11:33 AM
Hi,

I've got an issue with a HTML form that use to work fine on the website and then recently stopped working.

Once you input the information into the form and click on Submit, it produces the e-mail from my e-mail client, with the Send To email address, as well as the Subject, BUT it omits all of the information that is suppose to show in the body of the email (so the information that was filled out in the form).

Here is what the code looks like:

<form name="form1" method="post" onsubmit="return checkpasswords();" action="mailto:myname@mycompany.com?subject=Request for demonstration" >
<table cellpadding="7" cellspacing="7" style="font-weight:bold">
<tr>
<td width="150">Full Name:</td>
<td><input name="fullname" type="text" size="30" /></td>
</tr>
<tr>
<td>Email Address:</td>
<td><input type="text" name="emailadd" size="30" /></td>
</tr>
<tr>
<td>Company Name:</td>
<td><input type="text" name="coname" size="30" /></td>
</tr>
<tr>
<td>Address:</td>
<td><textarea name="coaddress" cols="26" rows="5"></textarea></td>
</tr>
<tr>
<td>Telephone Number:</td>
<td><input type="text" name="telno" size="30" /></td>
</tr>
</table>
<table cellpadding="7" cellspacing="7" style="font-weight:bold">
<tr>
<td>I would like more information on the products and <br />services offered by Acturis.</td>
<td width="50" align="right"><input name="tick1" type="checkbox" value="Yes" checked /></td>
</tr>
<tr>
<td>I would like someone to contact me to arrange a <br />demonstration.</td>
<td width="50" align="right"><input name="tick2" type="checkbox" value="Yes" checked /></td>
</tr>
<tr>
<td align="center"><br />
<input name="submit" type="submit" value="Submit" /></td>
<td>&nbsp;</td>
</tr>
</table>
</form>

Has anyone else had this experience and know of a solution? It seems to be happening on both IE8 & 9.

Thanks :confused:

clausrei
02-22-2012, 03:45 PM
Are you sure, this happens for the first time, or did it happen all the time but you did not notice ?

I think it works like it should. There is no way to send emails via HTML only. And if there is a way, please someone show us how !?

What you usually have on the server is a Sendmail Service or Daemon running, which sends the mail for you. For this reason you send the form entry parameter to a server side script in PHP or .ASP but not to a mailto: blaablal@hotmail.com. This scripts are quite simple and you probably will be able to download it from somewhere or get someone to write it for you.

And the difference looks like this: ( But sometimes you have to configure Sendmail as well where the problem starts. Only if it does not run on defaut settings. )

Example:


<form action="sendmail.php" method="post" enctype="text/plain" name="contact" id="contact">

coetzerl
02-22-2012, 04:23 PM
Clausrei,

Yes I'm sure it use to work as you simply use mailto:

I've since posting this thread also found out that it could be happening due to a Microsoft bug. I'm still looking into it though...



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum