...

View Full Version : Rollover images with CSS



roxana
02-11-2012, 08:39 PM
Hi,

I have three images (for cart, search and fax) in the left column navigator.

When I hover with the mouse over them, the background image is supposed to change position. I used the pixy method. All works well with all browsers ... except IE. In IE the hover state is shown, when the mouse is not hovering over the image.

I have tried endless hours, and at one point even got it to work. But then the line-heights needed tweaking, and after doing that, the roll over no longer worked. I tried, but I couldn't retrace my steps.

Could someone help me with that?

The link is http://www.segufixshop.eu/detail.php?recordID=1.php

Excavator
02-11-2012, 08:45 PM
Hello roxana,
It seems to work fine on this end. I looked at the site in FF11, IE9, IE8 and IE7. All seem to behave the same...unless I've misunderstood the question.

There are plenty of errors found by the validator that should be fixed. Especially the lack of DocType. See the links about DocTypes and Validation in my signature line.

roxana
02-11-2012, 08:54 PM
Thank you for helping.

Honestly, I don't know what just happened. Without changing it, it simply worked again. But also the line heights in IE8 and IE9 need adjusting again. I will try to get that, but not without backing up the working version first :)

The errors the validator found, is that a problem? I am not a coder, so I never took the time to look into that. I am just glad, when things work out.

Excavator
02-11-2012, 09:04 PM
The errors the validator found, is that a problem? I am not a coder, so I never took the time to look into that. I am just glad, when things work out.

Some are more of a problem than others. Without a DocType, IE is in quirksmode and that can cause unpredictable problems all over the place. Did you read the article on DocTypes? It's an important thing to know about and use.

roxana
02-11-2012, 11:55 PM
I ran into problems with the doc type once, where the browser would not display some European characters correctly. I thought I had taken care of that.

I will read the links in your signature and work at validating the site.

Thank you for pointing that out.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum