View Full Version : Hidden div not working as intended - Really starting to panic!

01-26-2012, 03:12 PM
I have an image map, with hidden divs below so that the lightbox the imagemap triggers will allow you to scroll through more than one image when the lightbox is triggered, this part is not working for some reason and I have no clue what Im doing wrong, how do I fix this?

my test site is set up at coy-design.com/test/mail.html


01-26-2012, 04:12 PM
Hello again Imorales,
Have a look at what these changes do for you:
markup -

<div class="hidden">
<img src="images/bb/120bb.jpg" title="Buyback Booklet" rel="lightbox[bb]" />
<img src="images/bb/bbpostcard.jpg" title="Buyback Postcard" rel="lightbox[bb]" />
<img src="images/bb/exclusivebb.jpg" title="Exclusive Buyback Booklet" rel="lightbox[bb]" />
<img src="images/bb/pac.jpg" title="Buyback Mail Pac" rel="lightbox[bb]" />
<!--end .hidden--></div>

And a little CSS -

top: 0px;


#container1 {

background: none repeat scroll 0 0 transparent;
height: 768px;
position: relative;
top: 0;
.hidden {display: none;}

01-26-2012, 04:37 PM
Its still not working :( am I being reallyyyy freaking dumb here or something? haha

01-26-2012, 05:17 PM
Could this be causing the error? I edited the js file slightly as the newer lightbox wasnt coded to work with image maps as i heard.

var imageNum = 0;
imageLink.rel = imageLink.getAttribute('rel');

if ((imageLink.getAttribute("rel") == 'lightbox')){
// if image is NOT part of a set, add single image to imageArray
this.imageArray.push([imageLink.href, imageLink.title]);

02-02-2012, 06:43 PM
The only way I could make it work was to not use a hidden div at all but to copy the image map locations for each group and just layer them ontop of each other, may not be the best way, but haha it worked like a charm. Thanks for your help!