...

View Full Version : html - design don't work proparly in Internet Explorer



webjoker
01-20-2012, 09:55 PM
Hello,

I have almost done my first website (yay!) but one problem is i think i miss a html tag to make this work proparly in Internet explorer (the design) here's the code:



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Strict//EN">
<html xmlns="http://www.w3.org/1999/xhtml">
<html>
<head>
<!--[if lt IE 9]>
<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->
<title>Piano och sånglektioner&mdash; För dig som vill nå lite längre i livet</title>
<meta http-equiv="content-type" content="text/html"; charset="utf-8" />
<link rel="stylesheet" type="text/css" charset="utf-8" media="screen" href="styleliendeborg.css">
<link rel="stylesheet" type="text/css" charset="utf-8" media="screen" href="menu.css">
<link rel="stylesheet" type="text/css" charset="utf-8" media="screen" href="om_mig.css">
<link rel="stylesheet" type="text/css" href="../../Documents and Settings/nti/Skrivbord/musihemsida/new/new2/menyer/Mapp fr endast hemsida/hej/pages/hem/content.css" />


</head>
<body>



<div id="content">
</div>

<div id="content">
</div>

<div id="container">

<div id="header">

<a href="http://taurus.nti.se/~joelin/index.html"><h1><b>Liendeborgs</b></h1> </a>
<a href="http://taurus.nti.se/~joelin/index.html"><h2><b>Börja spela, börja leva</b></h2></a>

<div id="wrapper">
<header><div class="titlebox">
</div>


<div class="menubox">
<nav class="menu">
<ul class="menu">
<li class="menu"><a href="http://taurus.nti.se/~joelin/index.html" class=\"menuActive\" class="menu">Hem</a></li>
<li class="menu"><a href="http://taurus.nti.se/~joelin/om_mig.html" class=\"menuActive\" class="menu">Om mig</a></li>
<li class="menu"><a href="http://taurus.nti.se/~joelin/betala.html" class=\"menuActive\" class="menu">Betala</a></li>
<li class="menu">
<a href="" class="menu" >Bilder</a>
<ul class="menu">
<li><a href="http://taurus.nti.se/~joelin/spelningar.html" class="menu">Spelningar</a></li>
<li><a href="http://taurus.nti.se/~joelin/lektioner.html" class="menu">Lektioner</a></li>
<li><a href="http://taurus.nti.se/~joelin/ovrigt.html" class="menu">Övrigt</a></li>
<div class="clear" />
</ul>
<div class="clear" />
</li>
<li class="menu"><a href="http://taurus.nti.se/~joelin/trubadur.html" class="menu">Trubadur</a>
<ul class="menu">
<li><a href="http://taurus.nti.se/~joelin/utbud.html" class="menu">Utbud</a></li>
<li><a href="http://taurus.nti.se/~joelin/lyssna.html" class="menu">Lyssna</a></li>
<div class="clear" />
</ul>
<div class="clear" />
</li>
<li class="menu"><a href="http://taurus.nti.se/~joelin/pedagog.html" class="menu">Pedagog</a>
<ul class="menu">
<li><a href="http://taurus.nti.se/~joelin/piano_sang.html" class="menu">Piano/sång</a></li>
<div class="clear" />
</ul>
<div class="clear" />
</li>
</nav>
</div>
<div class="menuboxa">
<nav class="home">
<ul class="home">
<div class="clear" />
</ul>
<div class="clear" />
</li>
</nav>
</div>
</header>


<p id="hem"><b>Hej,och välkomna till Liendeborgs egna musikhemsida!<br />
Låt mig gissa varför du har kommit hit? Kanske för <br />
att du vill lära spela piano och sjunga?</b></p>

<img src="http://taurus.nti.se/~joelin/Larsa.gif" alt="Smiley face" id="lars" />



</body>
</html>


and i think the problem is somewhere right, here:


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Strict//EN">
<html xmlns="http://www.w3.org/1999/xhtml">


I think i miss a tag there which gives Internet explorer the design i want!

Really hope you guys can help me soon, want to get this website finished!

Regards: Webjoker :)

teedoff
01-20-2012, 10:00 PM
and i think the problem is somewhere right, here:

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Strict//EN">
<html xmlns="http://www.w3.org/1999/xhtml">

I think i miss a tag there which gives Internet explorer the design i want!

Really hope you guys can help me soon, want to get this website finished!

Regards: Webjoker :)

lol maybe its because you declare two different doctypes?

webjoker
01-20-2012, 10:05 PM
oh well but when i change it, it still shows the same.... :) Thanks though

felgall
01-20-2012, 10:14 PM
oh well but when i change it, it still shows the same.... :) Thanks though

What did you change it to?

Also are you certain that there is no space or byte order mark before the < at the start of the doctype.

samih96
01-20-2012, 10:15 PM
it still shows the same....
Can you take a screen shot of your website and show us how it looks on IE9? and make sure you use one DOCTYPE.

I normally use <!DOCTYPE HTML> while building my websites.

teedoff
01-20-2012, 10:19 PM
Your invalid doctype is just one of 30 or so coding errors that you have in your markup. Still you need a single valid doctype to begin with. Then we can work on your other errors.

Can you post a link to your live test site as well?

webjoker
01-20-2012, 10:25 PM
oh yeah, sure... 2 secs!

webjoker
01-20-2012, 10:30 PM
http://taurus.nti.se/~joelin/betala.html

There it is i know it isn't a good website but i like to make websites, hope you can help me out! :)

webjoker
01-20-2012, 10:38 PM
Think i'll use this anyways:
[CODE]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
[CODE]

felgall
01-20-2012, 10:56 PM
You shouldn't use transitional for new web sites - transitional indicates that the page contains HTML 3.2 tags that were made obsolete in 1997 and which are yet to be replaces with their HTML 4 equivalents. (Those tags were intended to be dropped completely from HTML 5 however HTML 5 has downgraded their status from deprecated to obsolete meaning that they will continue to exist).

Appropriate doctypes to use for new sites being created now are:

for sites using only HTML 4 tags:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

for sites using any HTML 2 through HTML 5 tags (without selecting any particular HTML version):

<!DOCTYPE HTML>

There is no doctype specific to HTML 5 as that is still only a draft proposal.

Also there is no xmlns attribute on the <html> tag when you use HTML. That attribute identifies the namespace the tag belongs to when you use XHTML.

webjoker
01-20-2012, 11:07 PM
ok, thank you very much! I appreciate all help i can get right now, really...! Hope i can get some more help here. But once again thank you,felgall!

daretomk
01-21-2012, 01:57 AM
<!DOCTYPE html> is the doctype for HTML5 coding :D Use that in future

dofdiamond
01-21-2012, 12:03 PM
Thanks for Reply,

But i have same problem, when test my site on IE-tester there is no problem, but when i am going to check online in any IE 6.7.8.9 any IE i got some problem like DIV width and height change. Image logo also differ in each and every time.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum