...

View Full Version : strange shift key issue



ergibbs
01-15-2012, 12:28 AM
I cannot type a capital E with the right shift key, only the left one. The E is the only key that doesn't work with the right shift key. It's certainly not a huge issue, but I'm curious if there is something that I can do to correct it. This is an HP Pavilion laptop running Vista Ultimate.

Spookster
01-15-2012, 05:12 AM
I would probably check 2 things that might be affecting it. Check the regional settings to see if you are still using the right keyboard layout for your language. There are also various settings that can be applied there as well. The other thing you can check are the accessibility settings. You can check to see if maybe that key combination was redefined as some kind of accessibility shortcut. Also try bringing up the virtual keyboard in the accessibility options and see if it happens there as well.

ergibbs
01-15-2012, 11:52 AM
Thanks for the response. I don't see where anything has been remapped and the virtual keyboard works fine. I forgot to mention that the computer was initially set up with Spanish (Costa Rican sort) and then English (U.S. sort) was added. I have deleted English and re-added it, but I can't remove the Spanish sort, even if another language is added.

ergibbs
01-15-2012, 01:28 PM
In the registry, I supposedly have now mapped the right shift key to the left shift key but nothing has changed. The key mapping (prior to my monkeying around) for both the right shift and left shift keys was identical.

Crake
01-19-2012, 10:25 PM
Have you tried a different keyboard?

and i agre it probaley could be connect with connected with regional settings

type intl.cpl in run to access this

ergibbs
01-19-2012, 11:16 PM
Thanks for the reply. The keyboard is set up for both Spanish (Costa Rica sort) and English and it happens in both. I can't remove the Spanish since the laptop was originally set up in Spanish. I havenīt tried another keyboard, but I suspect it will work fine.

Crake
01-20-2012, 09:02 AM
Just because you set it up spanish you can still change it.....
Type intl.cpl into run:

Under the formats Tab:

Make sure the format is English

> Location Tab

Current location should be set to United Kingdom

Now go to the Keyboards & Languages tab and click change Keyboards
Make sure the default input language is set if not click the drop down menu and choose English (united Kingdom)

and then under installed services make sure EN English (united Kingdom) is the only keyboard if it isnt you may have to add it before removing the old one,

Hope this helps,

SteveO :thumbsup:

ergibbs
01-20-2012, 01:58 PM
Thanks. I can change the primary language, which I've done, but what I can't do is delete the Spanish keyboard to only leave the English one. I have it set up with Spanish (default) and English, which I added. The computer won't let me delete the Spanish keyboard; the option to delete is greyed out.

Crake
01-20-2012, 10:41 PM
Email me @ Steveosargent@gmail.com

wel set up a teamviewer and il see if i can help you remotley,

If you havnt used Teamviewer before Dont worry you can end the connect at any time you wish,

Cheers,

Steveo :thumbsup:

ergibbs
01-21-2012, 03:39 AM
Sending you an email. Thanks.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum