...

View Full Version : Script not showing up in some browsers



devonrs
01-04-2012, 09:04 AM
Not sure if I'm in the right category, apologies if I am not..

I have a small flash/javascript streaming mp3 player on my site that works fine in Chrome and Safari, but doesn't show up at all in Firefox, IE, or Opera.

the site is here: www.thehordeandtheharem.com/index2.html

the player is in the top left corner. I don't even know where to begin troubleshooting this as I didn't write the player myself, but copied it from another site. If anyone could shed any light on this for me I would be very grateful, thanks!

xelawho
01-04-2012, 03:09 PM
I get an error:
"hyj is not defined"

and I can't see why you have that hyj there on line 23 - have you tried removing it?

devonrs
01-05-2012, 07:40 AM
not sure what you're talking about.. i don't see hyj anywhere?

Philip M
01-05-2012, 07:43 AM
not sure what you're talking about.. i don't see hyj anywhere?

Use your error console.

22 }
23 hyj
24 Array.prototype.remove = function (element) {

I am surprised that it shows up in any browser.

devonrs
01-05-2012, 08:03 AM
ah, got it.. okay removed those lines, and am trying to clean up other errors from the console.. still no dice on the mp3 player though..

devonrs
01-05-2012, 08:45 AM
digging further i saw that their was a display:none tag on the CSS element, I removed that and now the buttons show up but the songs don't show up (unless you press "next" then the titles show up but they still won't play) - I don't know where to go from here or why it was set to display:none and yet still displayed in some browsers - also, the site that i copied this player from (mumfordandsons.com) has the CSS set the same (display:none) and it shows and plays just fine on all browsers - clearly I'm missing something else here but I can't figure out what.. anybody?

thanks!
jack

devonrs
01-05-2012, 09:21 AM
To make troubleshooting this easier I created a stripped down page with only the player and it's related CSS and javascript files - nothing else. There are no errors reported by the console and it works fine with Chrome and Safari, but only shows the buttons in other browsers and doesn't play the songs. Here's the test page:

http://thehordeandtheharem.com/test/

no idea where to go from here though.. thanks in advance for your help! jack



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum