...

View Full Version : noob ?'s re: application folder and app publishing



DanInMa
11-22-2011, 04:11 PM
hello all.
I primarily use classic asp and vbscript in my current environment. I took a class on visual studio 2008 and I am working on my first hello world app in .net.

my work server is iis 6.0with .net 2.0 enabled. I do not have admin access to it.
I recently completed a test page and when I built then debugged the app it ran fine.
When I publish it Im getting errors which google tell me is because I have nto set up the folder as an applicationj folder.

Can somsone point me to an article on how to do so or explain what steps I need to take in order to setup the page.

If i have to access the server, I'm curious if its common for you to have to do thigns that required server access often?

Inigoesdr
11-22-2011, 06:14 PM
What are the errors you are receiving? Often errors can be caused by permission issues on the site's folders.


If i have to access the server, I'm curious if its common for you to have to do thigns that required server access often?

Yeah, it's pretty common. Most server admins set up the server to be very restrictive, and IIS is setup to be pretty restrictive itself to minimize security issues.

DanInMa
11-22-2011, 06:21 PM
Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load the assembly 'App_Web_42ivdqoe'. Make sure that it is compiled before accessing the page.

Source Error:


Line 1: <%@ page language="C#" autoeventwireup="true" inherits="_Default, App_Web_42ivdqoe" %>
Line 2:
Line 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">



googling has turned up that the folder hasnt been properly setup as an application folder

alykins
11-22-2011, 07:03 PM
can i see your C# call to the file?
edit:
not the whole code behind- just the call ref

edit edit: and you said you are able to build this successfully? are you throwing an error publishing it or does that happen fine as well?

DanInMa
11-22-2011, 07:11 PM
build goes fine no errors. I recently installed vs2010. built the solution then published to the live server without setting up any application folder( dont even remember hearing abotu this in class) . Works fine on the dev server. the only thing Im really doing here is using web.config to limit access to the folder to an active directory group Im in, which does work on the dev side.

entire file is :

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title></title>
</head>
<body>
<form id="form1" runat="server">
<div>
hi there
</div>
</form>
</body>
</html>

alykins
11-22-2011, 07:20 PM
are you talking about site/application: ?
I think that section is if you want to make it part of an existing site...
are you running iis7?
in iis you can have the default site (or whatever site you make) A) have it's sub apps/sites/whatever you wanna call them... if it is working in dev but not prod i would say it is what Inigoesdr eluded to (and you seem to be on same track of-) it is most likely restictions in iis... also you may need to make little tweaks to iis for your app

DanInMa
11-23-2011, 01:37 AM
application, IIS6. I dont have access to the server environment and while they have .net installed it's technically unsupported because the person in charge of it has been there for years and theyve never dealt wit a .net environment so they dont know what to do with it :).

If i need changes on the server I have to have a pretty good idea of what needs to be changed so I can indicate that to them. Any suggestions on what needs to happen?

alykins
11-23-2011, 02:40 AM
honestly- I am horrible in iis... i know enough to be dangerous... i usually pass it on to my boss who runs the servers and all that happy fun stuff... sry :( hopefully someone else will be of more help

Inigoesdr
11-23-2011, 03:57 PM
I haven't run in to this error personally, but it looks like a problem in older versions of .NET 2.0(link (http://support.microsoft.com/kb/934839)). There is a workaround posted on that KB article as well as a hotfix, and it appears to have been fixed in .NET 2.0 SP1.

DanInMa
11-23-2011, 05:19 PM
I haven't run in to this error personally, but it looks like a problem in older versions of .NET 2.0(link (http://support.microsoft.com/kb/934839)). There is a workaround posted on that KB article as well as a hotfix, and it appears to have been fixed in .NET 2.0 SP1.

Ahhh. ok well that def helps. I'm already negotiating getting the .net version on the server updated to 3.5 - I would ask for 4 but I believe that will only run on IIS7

ty Inigoesdr



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum