...

View Full Version : Fatal error: Call to undefined function xmlrpc_encode_request()



jinxuowemeacoke
11-10-2011, 04:42 PM
This is an extremely frustrating issue for me. I'm experienced with linux and php but not enough to handle this properly. First I get this error when I try running a script to post to wordpress via xmlrpc on a new server:

Fatal error: Call to undefined function xmlrpc_encode_request() in /file/path/ at line 17

And so I immediately think "ok, there's a php extension missing", so after some googling I find that I need to run #yum install php-xmlrpc and unfortunately when I putty in and run that I get:


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.200p-sf.sonic.net
* extras: centos.mirror.facebook.net
* updates: mirror.5ninesolutions.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package php-xmlrpc available.
Nothing to do


So... this is where I'm stuck. Where do I get the package and how do I install it? I'm running Centos 5.

Any help would be majorly appreciated!

Spookster
11-10-2011, 10:43 PM
This is an extremely frustrating issue for me. I'm experienced with linux and php but not enough to handle this properly. First I get this error when I try running a script to post to wordpress via xmlrpc on a new server:

Fatal error: Call to undefined function xmlrpc_encode_request() in /file/path/ at line 17

And so I immediately think "ok, there's a php extension missing", so after some googling I find that I need to run #yum install php-xmlrpc and unfortunately when I putty in and run that I get:


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.200p-sf.sonic.net
* extras: centos.mirror.facebook.net
* updates: mirror.5ninesolutions.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package php-xmlrpc available.
Nothing to do


So... this is where I'm stuck. Where do I get the package and how do I install it? I'm running Centos 5.

Any help would be majorly appreciated!

I would guess you don't have the right repo enabled
Do you have this one enabled? http://www.webtatic.com/packages/php53/



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum