...

View Full Version : .mp3 File not found - flash player



dantra
11-09-2011, 09:59 PM
Hey guys, I'm trying to get an audio flash player on my site. The player shows up just the way it's supposed to however the files/.mp3 isn't being retrive. It keeps giving me a file not found. Here is what I have so far.


<script type="text/javascript" src="js/audio-player.js"></script>


<object type="application/x-shockwave-flash" data="http://www.mysite.com/audio/player.swf" id="audioplayer1" height="24" width="400">
<param name="movie" value="http://www.mysite.com/audio/player.swf">
<param name="FlashVars" value="playerID=audioplayer1&animation=no&encode=yes&initialvolume=100&remaining=no&noinfo=no&buffer=5&checkpolicy=no&rtl=no&bg=c2c2c2&text=333333&leftbg=4d3506&lefticon=ffffff&volslider=666666&voltrack=FFFFFF&rightbg=4f3207&rightbghover=999999&righticon=ffffff&righticonhover=FFFFFF&track=d1d1d1&loader=b81212&border=000000&tracker=b8ccff&skip=666666&titles=test2&soundFile=http://www.mysite.com/audio/test2.mp3" />
<param name="quality" value="high" />
<param name="menu" value="false" />
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#FFFFFF" />
</object>

dantra
11-10-2011, 01:25 AM
Never mind, I had a semicolon in the wrong place that threw everything off.

mtalk
11-10-2011, 06:10 AM
Ahh thats good to see you have sorted out your problem

dantra
11-11-2011, 05:02 AM
Ok, now that I got it to work how do I get it to play nice with IE I get a message that states:

"This page contains <object> tags that may not work properly in most recent versions of Internet Explorer. To correct this problem, you must convert these tags to browser-safe scripts."

Can anyone help me out with this. Do I have to use the embed tags and if so how do I do that? I tested it out in Firefox, Safari and Chrome with no problems. I only get this problem with IE.

Dan

dantra
11-12-2011, 06:38 AM
This is as far as I gotten. The player shows up just fine, exactly like I want it to look however the file doesn't load. Somehow I'm having difficulty getting the audio file to play. Any help is greatly appreciated.


<head>
<script type="text/javascript" src="swfobject.js"></script>
<script type="text/javascript">
swfobject.registerObject("", "9.0.0");
</script>
</head>



<div><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="312" height="24" name="audioplayer1">
<param name="movie" value="player.swf" />
<param name="loop" value="false" />
<param name="menu" value="false" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#ffffff" />
<param name="flashvars" value="animation=yes&amp;remaining=no&amp;noinfo=no&amp;buffer=5&amp;checkpolicy=no&amp;rtl=no&amp;bg=dcdac5&amp;text=4d3506&amp;leftbg=4d3 506&amp;lefticon=ececdf&amp;volslider=8c8774&amp;voltrack=ececdf&amp;rightbg=4f3207&amp;rightbghover=999999&amp;righticon=ec ecdf&amp;righticonhover=ececdf&amp;track=dcdac5&amp;loader=8c8774&amp;border=dcdac5&amp;tracker=ebeade&amp;skip=666666&amp;sound File=http://www.mysite.com/audio/test2.mp3" />
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="player.swf" width="312" height="24">
<param name="loop" value="false" />
<param name="menu" value="false" />
<param name="quality" value="high" />
<param name="wmode" value="transparent" />
<param name="bgcolor" value="#ffffff" />
<param name="flashvars" value="animation=yes&amp;remaining=no&amp;noinfo=no&amp;buffer=5&amp;checkpolicy=no&amp;rtl=no&amp;bg=dcdac5&amp;text=4d3506&amp;leftbg=4d3 506&amp;lefticon=ececdf&amp;volslider=8c8774&amp;voltrack=ececdf&amp;rightbg=4f3207&amp;rightbghover=999999&amp;righticon=ec ecdf&amp;righticonhover=ececdf&amp;track=dcdac5&amp;loader=8c8774&amp;border=dcdac5&amp;tracker=ebeade&amp;skip=666666&amp;sound File=http://www.mysite.com/audio/test2.mp3" />
<!--<![endif]-->
<a href="http://www.adobe.com/go/getflashplayer">
<img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
</a>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
</div>

dantra
11-18-2011, 07:14 PM
Never mind, got it working.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum