View Full Version : IIS .net v4 integrated access denial errors

10-31-2011, 11:29 PM
I'm running Windows 7 with IIS7.

I created a new asp.NET site and am trying to have it run in integrated mode.

With impersonation disabled, I get a 401.3 error regardless of which pipeline mode I am using.

Server Error in '/' Application.
Access is denied.
Description: An error occurred while accessing the resources required to serve this request. You might not have permission to view the requested resources.

Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists). Ask the Web server's administrator to give you access to 'C:\Users\God\Desktop\aspSite'.

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

If I enable impersonation, it works fine in Classic mode, but I get a 500.24 in integrated mode.

Error Summary
HTTP Error 500.24 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.
Detailed Error Information
Module ConfigurationValidationModule
Notification BeginRequest
Handler ExtensionlessUrl-Integrated-4.0
Error Code 0x80070032
Requested URL http://newcomb:80/
Physical Path C:\Users\God\Desktop\aspSite
Logon Method Not yet determined
Logon User Not yet determined
Most likely causes:

system.web/identity@impersonate is set to true.

Things you can try:

If the application supports it, disable client impersonation.
If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
Move this application to an application pool using Classic .NET mode - for example, %SystemRoot%\system32\inetsrv\appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"

(You can set "Classic .NET AppPool" to the name of another application pool running in Classic managed pipeline mode)

As far as I know, the only way to fix the 500.24 error is to disable impersonation. I Have no problem with this, but I can't figure out how to fix the 401.3 error.

Does anyone have any ideas?


11-03-2011, 04:34 AM
Okay, I was able to resolve the issue by setting the physical path credentials of my site to the specific user of the folder. To do this all I need to do is edit the advanced settings of the site from the IIS manager.

11-03-2011, 01:42 PM
sry- I did look at this to attempt to help; I am horrible in iiS :eek:

11-03-2011, 03:43 PM
sry- I did look at this to attempt to help; I am horrible in iiS :eek:

Yeah, it's all your fault! I will never come to coding forums ever again!

As long as the issue gets resolved, that is all that matters. Hopefully, this post will be of help to anyone else having the same issue.