...

View Full Version : Resolved Only Firefox Renders This Page



gbsothere
10-17-2011, 04:18 AM
I'm working on a page for a church, as a favor. I'm not much of a coder; it's a hobby and with free, unfortunately, one gets what one pays for. If you look at this test page link on Firefox, you should be able to see what the page is meant to look like.

Test Page (http://whereitestmystuff.com/box)

No other browser, however, is displaying the page (so far). I've tried Safari, Opera, OmniWeb, Firefox and, although I am unable to test IE, since I do everything on a Mac and don't have a PC, I had a friend test on IE9 (which always gives me fits) and no joy. Now, I do understand that using wmode="opaque" in the embed tag and
<param name="wmode" value="opaque"/> in the object tag wreaks havoc with IE9, but also with every other browser other than Firefox? Really? (I've also tried "transparent" with the same results.)

As you can see (if you're viewing with Firefox), I wanted to float a "picture frame" over the .swf object, which is why I used the wmode value.

My question is: is using wmode=opaque really what's throwing all these browsers, except Firefox, into a tizzy? I knew IE9 would flip out, but I was surprised at the others. For this intro page, I'm only using the css you see in the page's header. I'm sure this will be something apparent to you guys, but I'm clueless and would appreciate any help.

Thanks!

_Aerospace_Eng_
10-17-2011, 05:27 AM
This has nothing to do with flash. It is an HTML error.

<style type="text/css">

#body {

margin:0px;padding:0px;text-align:center;min-width:857px;

background: #708090;background-image:url('images/metal.jpg');background-repeat:repeat;

}

#centerwrapper {text-align:left;width:950px;margin-left:auto;margin-right:auto;}

<!--

*|*:-moz-any-link:focus {

outline-width: 0 !important;

}

</style>

Remove the <!--

gbsothere
10-17-2011, 01:35 PM
That's brilliant. You're brilliant; thanks. I'd fetched that scrap of code from another of my sites (that doesn't use flash) to keep those annoying dotted borders from forming on clicked items (Firefox) and that bit of <!-- got caught in the paste.

I'm seeing this on Safari and Omniweb, now, although I'll have to ask an IE9 user to check. Opera, on the other hand, is only displaying a large "play" button (that completely fills the flash area) but not the flash, itself. Autoplay is set to "true". Since that field is a hyperlink, clicking it just goes to the next page, so the flash can't be viewed. I suppose that's a Google for me.

Thanks so much for weighing in.

_Aerospace_Eng_
10-17-2011, 03:57 PM
I think opera has a setting to allow users to "click to play" or play automatically. It works fine for me in opera. No play button.

This is the setting

Menu > Settings> Preferences > Advanced > Content > Uncheck Enable Plugins Only On Demand

It works in IE9 but the "frame" part isn't centered.

gbsothere
10-17-2011, 04:05 PM
I added a redirect in the heading for Opera users to be able to just skip that page altogether.

Thanks for your help; much appreciated.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum