...

View Full Version : Getting invisible underscores under hyperlinked images



Democrazy
09-17-2011, 10:30 AM
For some strange reason I am getting an invisible underscore under my hyperlinked images. Does anyone know why this is happening or how I can stop it from happening?

Screen shot:
http://i54.tinypic.com/r6zqx1.png

Code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<TITLE></TITLE>
<META content="charset=windows-1252;text/html" http-equiv="content-type">
<STYLE type="text/css">
BODY {
color: white;
font-family: verdana
}
DIV.main {
background-color: black;
height: 636px;
left: 50%;
margin-left: -635px;
margin-top: -307px;
position: absolute;
top: 50%;
width: 1270px
}
TABLE.categorylist {
background-color: green;
margin-left:7px;
margin-top: 30px
}
TR.categorylist {
height: 174px
}
TD.categorylist {
text-align: center;
width: 150px
}
IMG.link {
border: 0px;
margin-top: 5px
}
</STYLE>
<DIV>
<DIV class="main">
<TABLE border="1" cellpadding="0px" cellspacing="19px" class="categorylist">
<TR class="categorylist">
<TD class="categorylist">
<A href="/1">1</A>
<A href="/1"><IMG alt="" class="link" src="1.png"></A>
</TD>
<TD class="categorylist">
<A href="/2">2</A>
<A href="/2"><IMG alt="" class="link" src="2.png"></A>
</TD>
</TR>
</TABLE>
</DIV>
</DIV>

vikram1vicky
09-17-2011, 10:58 AM
Use following code:


a {
text-decoration:none;
}

Democrazy
09-17-2011, 11:03 AM
Hey man,

haha yeah it was the first thing I tried.. doesn't work. :S

Kremlin
09-17-2011, 11:41 AM
not as an answer to your question, but you should start by getting the tags right. Head, Body etc.

Kremlin
09-17-2011, 11:45 AM
margin-bottom:0px might work

your row has a set height of 174, that could be a factor as well



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum