View Full Version : @font-family external link not working in FireFox

DG Kim
09-02-2011, 04:29 AM

I'm currently making a CSS for a site that I do not control (i.e. I don't have FTP access, but I have a blog on the site that I can manipulate the CSS). I'm using fonts from my home site, via this code:

@font-face {
font-family: 'ActionMan';
src: url('http://www.cyneer.com/dojo_styles/fonts/ActionMan/Action_Man-webfont.eot');
src: url('http://www.cyneer.com/dojo_styles/fonts/ActionMan/Action_Man-webfont.eot?#iefix') format('embedded-opentype'),
url('http://www.cyneer.com/dojo_styles/fonts/ActionMan/Action_Man-webfont.woff') format('woff'),
url('http://www.cyneer.com/dojo_styles/fonts/ActionMan/Action_Man-webfont.ttf') format('truetype'),
url('http://www.cyneer.com/dojo_styles/fonts/ActionMan/Action_Man-webfont.svg#ActionManRegular') format('svg');
font-weight: normal;
font-style: normal;

This code works perfectly fine in Chrome and IE (not sure about opera, haven't tested yet), but for some reason, FireFox won't load the fonts from my site... is there something I can do about this?

I tested the fonts being loaded on the site itself, and that works perfectly fine... not sure why it won't load.

Thanks in advance,
DG Kim

DG Kim
09-02-2011, 06:59 AM
Okay, I figured it out. For the future people who stumble upon this post via a google search, look here:



09-02-2011, 11:07 AM
Yeah, just was going to say, as in the other thread just recently: Don’t use the domain name in the file paths. Use relative or domain independent absolute paths.