...

View Full Version : Reports of a black box!



tanyaf
08-13-2011, 10:49 PM
Hi! I will preface this with a disclaimer. I am not a coder. I'm very interested, but neither trained nor educated.

I made some html changes to this page to accommodate my boss's wishes:http://fizzcorp.com/speaking.php#

Everything looks normal to me, but a couple of people have reported seeing a black box where a microphone image should be. This microphone image is new. I added this new .jpg to the stylesheet where all the other banner images are referenced.

When users who report seeing a black box refresh their pages, often the banner appears. But most visitors to this page will only visit once and will probably not refresh it if images aren't displaying correctly.

There was no problem showing the previous image before I modified the stylesheet with the new image file, but I can't figure out what the problem could be. Also, I never see this black box, even when I reset my browser. Everything displays correctly for me and for most of the friends I ask to check it out. Just yesterday my boss sent the link to a colleague and was very irritated to find out that the image was not displaying properly. Are you seeing a large black box when you visit the page?

Many thanks in advance,
Tanya

PS - I can of course paste the CSS for the stylesheet and the html for the page in question if that would be helpful.

tracknut
08-13-2011, 11:27 PM
I would clean up the validation errors (http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Ffizzcorp.com%2Fspeaking.php%23) in the file. Some of these flaky things seem to happen when two browsers (possibly because of slightly different versions) process errors differently.

Dave

tanyaf
08-13-2011, 11:41 PM
Thank you very much for this! What an embarrassing number of errors. I'll start working on those right away. Out of curiosity, were you able to see the microphone banner?

tracknut
08-13-2011, 11:49 PM
Yes, it looks fine for me in Firefox...

Dave



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum