...

View Full Version : Drop down menu not working in IE



DanHardy
08-12-2011, 04:40 PM
Hi all,

Due to some research I am aware this is a notorious problem, however I am yet to find the solution. The problem is as the title says.

Here is the table used:




<ul id="menu">

<li><a class="titlelinktest" href="web.php">SERVICES</a>
<ul>
<li><a href="web.php">DESIGN</a></li>
<li><a href="web.php">COMMUNICATIONS</a></li>
<li><a href="web.php">MARKETING</a></li>
<li><a href="web.php">EVENTS</a></li>
<li><a href="web.php">WEB DESIGN</a></li>
</ul>
</li>

</ul>



...and the CSS




ul {
z-index:100;
position:relative;
margin: 0;
padding: 0;
list-style: none;

}
ul li {
display: block;
position:relative;
float: left;

text-align:left;

height:auto;
}
li ul { display: none; }
ul li a {
display: block;
text-decoration: none;
white-space: nowrap;
}

ul li a:hover {text-decoration:underline; }
li:hover ul {
display: block;
position: fixed;
width:auto;
height:10px;


}
li:hover li {
float: none;
font-size: 11px;
width:140px;
height:28px;

background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navbg.png);
background-repeat:repeat-x;

}


ul li a:hover {text-decoration:underline; }
li:hover ul {
display: block;
position: fixed;
width:auto;
height:10px;




}
li:hover li a{
float: none;
font-size: 11px;
width:150px;
height:28px;
padding-left:10px;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navbg.png);
background-repeat:repeat-x;

}


li:hover ul li a:hover{
width:150px;
height:28px;
padding-left:10px;
background-repeat:repeat-x;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navbg2.png);
text-decoration:none;
}


li a.titlelinktest {

width:75px;
text-decoration:none;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navarrow.png);
background-repeat:no-repeat;
background-position:right 10px;
}

li:hover a.titlelinktest {
color:#00b0ba;
text-decoration:none;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navarrow2.png);
background-repeat:no-repeat;

}

li a.titlelinktest2 {

width:160px;
text-decoration:none;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navarrow.png);
background-repeat:no-repeat;
background-position:right 10px;
}

li:hover a.titlelinktest2 {
color:#00b0ba;
text-decoration:none;
background-image:url(http://www.garethhardy.com/shine/wp-content/themes/twentyeleven/images/navarrow2.png);
background-repeat:no-repeat;

}

a.titlelink:hover {
text-decoration:none;
color:#00b0ba;
}



To avoid wasting time I have the correct Doctype and meta tag defined.

Thanks in advance for your help.

Dan

teedoff
08-12-2011, 06:05 PM
A link to your site would be more useful, that way we dont have to recreate your page. ;)

DanHardy
08-12-2011, 06:38 PM
A link to your site would be more useful, that way we dont have to recreate your page. ;)

http://garethhardy.com/shine/

There is the link.

Also it is coded in Wordpress. Not sure if that make a difference but thought I should mention it :)



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum