...

View Full Version : I'm using an... Iframe. Need help!



Jackage
08-10-2011, 03:00 AM
Hello everyone,
As you may or may not know, I run my own internet radio station. My radio station has a variety of ways to tune into the station, and one way is Browse 'n' Play.

Browse 'n' Play allows you to browse the web whilst being tuned in. The Browse 'n' Play radio panel is located at the bottom of every page so you can control the radio at your fingertips!

What I have done, is set up Google in the iframe and having the bar at the bottom which has my radio:


http://planetvolume.com/demo

I have two problems. My problems are:

1) Due to cross browsers, my Browse 'n' Play feature only works in a few browsers, like Chrome, but not IE9 or older ones. The Iframe's height it extremely small, about a quarter of the page!

2) My second problem is when it is working fine (on Chrome), when I am using Google search and browsing the net, the Iframe gradually decreases in height after every link I click! After about 9 or 10 different pages my iframe decreases so much it's fustrating!

If you want the codes, let me know. Otherwise you can view source at http://planetvolume.com/demo

Please note: I am not amazing at coding, so please do try to keep your answer as basic as possible! :thumbsup:

Thanks alot! :cool:

sunfighter
08-10-2011, 07:15 AM
Link does not work.

Jackage
08-10-2011, 01:30 PM
Thats strange, it works for me. Make sure the 'd' in demo is lowercase? Using cpanel the directory name has to be exact

sunfighter
08-10-2011, 07:06 PM
Thats strange, it works for me. Make sure the 'd' in demo is lowercase? Using cpanel the directory name has to be exact

message is:
Bandwidth Limit Exceeded

Jackage
09-06-2011, 12:30 PM
new link www.planetvolume.com/beta/browse-n-play

alykins
09-06-2011, 03:47 PM
I think the problem is in your implementation of the ajax control you used... did you modify it in any way when you inserted it? looking at the examples of your site (http://www.planetvolume.com/beta/browse-n-play/) and then looking at the example script on this site (http://www.dynamicdrive.com/dynamicindex17/stickybar.htm) I clearly see your issue... I am not too sure what exactly is causing the issue though... I am thinking... if you use developer tools (microsofts equiv to inspect element (chrome) and firebug) you can see that client side scripting write below you ajax created div a section that reads


<style type="text/css">
then is gives some styling, and then...
text empty node

then it just ends... there is never a </style> set... and the <style> set needs to be in the header... This does not occur on the example site and hence why I think everything works fine on the example site; and leads me back to the initial question of did you modify the control somehow when you inserted it?
As to your "chrome" issue.... I tried and tried and found more info than I cared to know about cats (I googled cats through your site) and never did I see the shrinking issue. ? possibly fixed?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum