...

View Full Version : My .htaccess is getting bad flag delimiters on hotlink protection



cineweekly.com
08-04-2011, 06:37 AM
I was trying to exclude my sites and some popular sites from hotlink protection when I got this error:


Apache detected an error in the Rewrite config.

Syntax error on line 42 of /home1/ustucom/public_html/.htaccess.DpgQi75EJSoL0rMs1nLME9I0esRMVLMb:
RewriteRule: bad flag delimiters

Please try again.

Line 42 is red below.


# Use PHP5 Single php.ini as default
AddHandler application/x-httpd-php5s .php

RewriteEngine on

ErrorDocument 404 /errors/404.html

RewriteBase /

RewriteCond %{HTTP_HOST} ^cineweekly.com$
RewriteRule ^(.*)$ "http\:\/\/www\.cineweekly\.com\/$1" [R=301,L]

RewriteCond %{HTTP_HOST} ^u-stu.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.u-stu.com$
RewriteRule ^/?$ "http\:\/\/www\.cineweekly\.com\/" [R=301,L]

RewriteCond %{HTTP_HOST} ^cineweekly.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.cineweekly.com$
RewriteRule ^images\/?$ "http\:\/\/www\.cineweekly\.com\/" [R=301,L]

RemoveHandler .html .htm
AddType application/x-httpd-php .php .htm .html
RewriteCond %{HTTP_HOST} ^cineweekly.com$ [OR]
RewriteCond %{HTTP_HOST} ^www.cineweekly.com$
RewriteRule ^index\.html$ "http\:\/\/www\.cineweekly\.com\/" [R=301,L]

RewriteCond %{HTTP_REFERER} !^http://private.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://private.cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://private.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://private.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://forum.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://forum.cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://u-stu.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://u-stu.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.private.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.private.cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.private.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.private.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.forum.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.forum.cineweekly.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.u-stu.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.u-stu.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.facebook.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.facebook.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.reddit.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.reddit.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.stumbleupon.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.stumbleupon.com$ [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ http://oi52.tinypic.com/28k12xk.jpg [R,NC]

cineweekly.com
08-10-2011, 09:52 PM
Six day bump. I really would appreciate help on this.

Cags
08-11-2011, 08:49 AM
At a glance I don't see anything wrong with it. If I had to guess I'd probably assume that it's something to do with a non-visible character. Open the file with an editor that supports showing invisible characters. I'm guessing that there's either an unwanted character in there or the wrong line ending for one - or more - of the lines close to that one.

Inigoesdr
08-12-2011, 12:22 AM
I don't see anything wrong with that line. Are you sure you are looking in the correct file? The error has an unusual .htaccess filename.

cineweekly.com
08-12-2011, 09:10 AM
Checked for non-visible characters in Open Office Writer, nothing. 100% sure that's the .htaccess file and it's named .htaccess Don't know where the .DpgQi75EJSoL0rMs1nLME9I0esRMVLMb is coming from. It's still blocking Facebook, Reddit, and StumbleUpon. All three are below the line of the error.

Cags
08-12-2011, 01:36 PM
Just as a side note, you only need half the amount of rules you have at most.


RewriteCond %{HTTP_REFERER} !^http://private.cineweekly.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://private.cineweekly.com$ [NC]

...could be rewritten as simply...


RewriteCond %{HTTP_REFERER} !^http://private.cineweekly.com.*$ [NC]

...or even better...


RewriteCond %{HTTP_REFERER} !^http://private\.cineweekly\.com [NC]

cineweekly.com
08-12-2011, 09:32 PM
I was using cPanels built in hotlink protection. I don't know jack about Apache that's why I posted here. cPanel is where the error in the OP originated.

Cags
08-13-2011, 06:47 AM
Personally I'd try copying the content you posted on here into a new file, remove and re-insert all the newlines, just to be sure and pasted it back into cPanel. Nobody can spot a mistake in the content you listed.

Of course the other possibility is that there isn't an error. Due to the strange filename displayed in the error message perhaps your server is doing some pre-processing on the file, meaning it could be changed before apache attempts to read it.

cineweekly.com
08-13-2011, 10:03 PM
Personally I'd try copying the content you posted on here into a new file, remove and re-insert all the newlines, just to be sure and pasted it back into cPanel. Nobody can spot a mistake in the content you listed.

Of course the other possibility is that there isn't an error. Due to the strange filename displayed in the error message perhaps your server is doing some pre-processing on the file, meaning it could be changed before apache attempts to read it.

I did that and even rearranging the sites it still says the error is on line 42 every time. There has to be an error because Facebook shows my hotlink image instead of those on my site.

EDIT: Apparently it's a known issue at HostMonster. I was told by customer support to open a support ticket, if anyone cares I can give you an update later.

taxitoss
05-02-2013, 08:47 AM
Hi,

I am using WAMP with Drupal 7. I enabled the mod_rewrite module in httpd.conf to enable clean url's in drupal however since then I am unable to run my website due to 500 internal server error. When checked the Apache log I see ".htaccess: RewriteRule: bad flag delimiters". I am unable to figure out the reason for this error.

Below is the content for .htaccess placed in website root


#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)(|~|\.sw[op]|\.bak|\.orig|\.save)?$|^(\..*|Entries.*|Repository|Root|Tag|Template)$|^#.*#$|\.php(~|\.sw[op]|\.bak|\.orig\.save)$">
Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php index.html index.htm

# Override PHP settings that cannot be changed at runtime. See
# sites/default/default.settings.php and drupal_environment_initialize() in
# includes/bootstrap.inc for settings that can be changed at runtime.

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
php_flag magic_quotes_gpc off
php_flag magic_quotes_sybase off
php_flag register_globals off
php_flag session.auto_start off
php_value mbstring.http_input pass
php_value mbstring.http_output pass
php_flag mbstring.encoding_translation off
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
# Enable expirations.
ExpiresActive On

# Cache all files for 2 weeks after access (A).
ExpiresDefault A1209600

<FilesMatch \.php$>
# Do not allow PHP scripts to be cached unless they explicitly send cache
# headers themselves. Otherwise all scripts would have to overwrite the
# headers set by mod_expires if they want another caching behavior. This may
# fail if an error occurs early in the bootstrap process, and it may cause
# problems if a non-Drupal PHP file is installed in a subdirectory.
ExpiresActive Off
</FilesMatch>
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
RewriteEngine on

# Set "protossl" to "s" if we were accessed via https://. This is used later
# if you enable "www." stripping or enforcement, in order to ensure that
# you don't bounce between http and https.
RewriteRule ^ - [E=protossl
RewriteCond %{HTTPS} on
RewriteRule ^ - [E=protossl:s]

# Block access to "hidden" directories whose names begin with a period. This
# includes directories used by version control systems such as Subversion or
# Git to store control files. Files whose names begin with a period, as well
# as the control files used by CVS, are protected by the FilesMatch directive
# above.
#
# NOTE: This only works when mod_rewrite is loaded. Without mod_rewrite, it is
# not possible to block access to entire directories from .htaccess, because
# <DirectoryMatch> is not allowed here.
#
# If you do not have mod_rewrite installed, you should remove these
# directories from your webroot or otherwise protect them from being
# downloaded.
RewriteRule "(^|/)\." - [F]

# If your site can be accessed both with and without the 'www.' prefix, you
# can use one of the following settings to redirect users to your preferred
# URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
#
# To redirect all users to access the site WITH the 'www.' prefix,
# (http://example.com/... will be redirected to http://www.example.com/...)
# uncomment the following:
# RewriteCond %{HTTP_HOST} .
# RewriteCond %{HTTP_HOST} !^www\. [NC]
# RewriteRule ^ http%{ENV:protossl}://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
#
# To redirect all users to access the site WITHOUT the 'www.' prefix,
# (http://www.example.com/... will be redirected to http://example.com/...)
# uncomment the following:
# RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
# RewriteRule ^ http%{ENV:protossl}://%1%{REQUEST_URI} [L,R=301]

# Modify the RewriteBase if you are using Drupal in a subdirectory or in a
# VirtualDocumentRoot and the rewrite rules are not working properly.
# For example if your site is at http://example.com/drupal uncomment and
# modify the following line:
# RewriteBase /drupal
#
# If your site is running in a VirtualDocumentRoot at http://example.com/,
# uncomment the following line:
# RewriteBase /

# Pass all requests not referring directly to files in the filesystem to
# index.php. Clean URLs are handled in drupal_environment_initialize().
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} !=/favicon.ico
RewriteRule . index.php [L]

# Rules to correctly serve gzip compressed CSS and JS files.
# Requires both mod_rewrite and mod_headers to be enabled.
<IfModule mod_headers.c>
# Serve gzip compressed CSS files if they exist and the client accepts gzip.
RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}\.gz -s
RewriteRule ^(.*)\.css $1\.css\.gz [QSA]

# Serve gzip compressed JS files if they exist and the client accepts gzip.
RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}\.gz -s
RewriteRule ^(.*)\.js $1\.js\.gz [QSA]

# Serve correct content types, and prevent mod_deflate double gzip.
RewriteRule \.css\.gz$ - [T=text/css,E=no-gzip:1]
RewriteRule \.js\.gz$ - [T=text/javascript,E=no-gzip:1]

<FilesMatch "(\.js\.gz|\.css\.gz)$">
# Serve correct encoding type.
Header set Content-Encoding gzip
# Force proxies to cache gzipped & non-gzipped css/js files separately.
Header append Vary Accept-Encoding
</FilesMatch>
</IfModule>
</IfModule>


Please help. Thanks in advance.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum