...

View Full Version : Dropdown Navigation Box not working



irishpeck
07-25-2011, 01:01 PM
Hi Guys i need some urgent help with a dropdown navigation for a client. Basically i have created a dropdown navigation for a client which is working on almost all pc's except for my clients laptop and some other pc's is there anyway to resolve this??? It seems to be in Internet Explorer only though as its working on Firefox on his same laptop?? The website is http://www.wsca.ie

teedoff
07-25-2011, 02:43 PM
ummm well you dont say what the issue is. Whats wrong with your drop down menu? It seems to be functional for me in IE8.

irishpeck
07-25-2011, 03:44 PM
Ok its a suckerfish menu but its just not dropping down on my clients laptop? Basically the links are showing up like they are meant to but when i scroll over them with my mouse on his laptop the dropdown is not actually happening basically nothing is happening? Here is the code:

This is the html navigation code -


<br><!-- Navigation -->
<br><br><p><ul id="suckerfishnav" class="sfmenu">
<li><a href="index.html">Home</a>
<li><a href="#">Why Us</a>
<ul>
<li><a href="#">Individual Training</a>
<ul><li><a href="individual.html">Male & Female Body Toning & Fat Loss</a>
<li><a href="olderadult.html">Older Adult Strength & Conditioning</a>
<li><a href="youthstrength.html">Youth Strength & Conditioning</a>
<li><a href="core.html">Core Strength & Flexibility</a>
<li><a href="postural.html">Corrective & Postural Exercise Design</a>
</ul></li>


<li><a href="#.html">Sports Specific Training</a>
<ul><li><a href="gaa.html">GAA</a>
<li><a href="handball.html">Handball</a>
<li><a href="soccer.html">Soccer</a>
<li><a href="rugby.html">Rugby</a>
<li><a href="athletics.html">Athletics</a>
<li><a href="mma.html">MMA</a>
<li><a href="boxing.html">Boxing</a>
<li><a href="martialarts.html">Martial Arts</a>
<li><a href="tennis.html">Tennis</a>
<li><a href="triathletes.html">Tri-Athletes</a>
<li><a href="cycling.html">Cycling</a>
<li><a href="running.html">Running</a>
<li><a href="swimming.html">Swimming</a>
<li><a href="golf.html">Golf</a>
<li><a href="rowing.html">Rowing</a>
<li><a href="hockey.html">Hockey</a>
<li><a href="basketball.html">Basketball</a>
</ul></li>
</ul></li>

<li><a href="#">How We Work</a>
<ul>
<li><a href="individualtraining.html">Individual Training</a>
<li><a href="howwework.html">Sports Specific Training</a>
</li>
</ul>



<li><a href="#">Our Team</a>
<ul>
<li><a href="damienwade.html">Managing Director - Damien Wade</a></li>
<li><a href="loughlingannon.html">Coaching Director - Loughlin Gannon</a></li>
<li><a href="ciaranpower.html">Program Design - Ciaran Power</a></li>
<li><a href="pauljordan.html">Program Design - Paul Jordan</a></li>
<li><a href="kevincogley.html">Coach - Kevin Cogley</a>
<li><a href="eddiebolger.html">Coach - Eddie Bolger</a>
<li><a href="damienbyrne.html">Coach - Damien Byrne</a>
<li><a href="paddymcdonald.html">Coach - Paddy McDonald</a>
<li><a href="johnweldon.html">Coach - John Weldon</a></li>
<li><a href="paulroberts.html">Coach - Paul Roberts</a></li>
<li><a href="marysutherland.html">Coach - Mary Sutherland</a>
<i><li><a href="eoinlacey.html">Functional Medicine Practitioner / Consultant - Eoin Lacey</a></li></i>
</ul></li>


<li><a href="ourfacility.html">Our Facility</a>

<li><a href="#">Our Services</a>
<ul>
<li><a href="nutritionist.html">Nutrition</a>
<li><a href="cryotherapy.html">Cryotherapy</a>
<li><a href="physio.html">Physiotherapy</a>
<li><a href="physicaltherapist.html">Physical Therapy</a>
<li><a href="osteopath.html">Osteopathy</a>
<li><a href="acupuncture.html">Acupuncture</a>
<li><a href="sportspsychology.html">Sports Psychology</a>
<li><a href="functionalmedicine.html">Functional Medicine</a>
</ul></li>


<li><a href="testimonials.html">Testimonials</a>
<li><a href="gallery.html">Media</a>
<li><a href="contact.html">Contact Us</a>

</ul>
<!-- end Navigation -->


And this is the CSS -

#suckerfishnav {
background:#000000 url(../images/dark_bg.png) repeat-x left top;
font-size:16.5px;
font-family:Helvetica;
width:100%;]
z-index:1;
}
#suckerfishnav, #suckerfishnav ul {
float:left;
list-style:none;
line-height:25px;
padding:0px;
border:0px solid #aaa;
margin:8px;
width:100%;
z-index:1;
}
#suckerfishnav a {
display:block;
color:#fff;
text-decoration:none;
padding:0px 10px;
z-index:1;
}
#suckerfishnav li {
float:left;
padding:2px;
z-index:1;
}
#suckerfishnav ul {
position:absolute;
left:-999em;
height:auto;
width:101px;
margin:0;
line-height:1;
border:0;
border-top:1px solid #666666;
z-index:1;
}
#suckerfishnav li li {
background:#000000 repeat-x;
width:300px;
border-left:1px solid #9f0b0b;
border-right:1px solid #9f0b0b;
font-family:helvetica,sans-serif;
}
#suckerfishnav li li a {
padding:7px 7px;
width:300px;
font-size:11px;
color:#ffffff;
}
#suckerfishnav li ul ul {
margin:0px 0 0 50px;
}
#suckerfishnav li li:hover {
background:#9f0b0b;
}
#suckerfishnav li ul li:hover a, #suckerfishnav li ul li li:hover a, #suckerfishnav li ul li li li:hover a, #suckerfishnav li ul li li li:hover a {
color:#ffffff;
}
#suckerfishnav li:hover a, #suckerfishnav li.sfhover a {
color:#fff;
}
#suckerfishnav li:hover li a, #suckerfishnav li li:hover li a, #suckerfishnav li li li:hover li a, #suckerfishnav li li li li:hover li a {
color:#CDCDCD;
}
#suckerfishnav li:hover ul ul, #suckerfishnav li:hover ul ul ul, #suckerfishnav li:hover ul ul ul ul, #suckerfishnav li.sfhover ul ul, #suckerfishnav li.sfhover ul ul ul, #suckerfishnav li.sfhover ul ul ul ul {
left:-999em;
}
#suckerfishnav li:hover ul, #suckerfishnav li li:hover ul, #suckerfishnav li li li:hover ul, #suckerfishnav li li li li:hover ul, #suckerfishnav li.sfhover ul, #suckerfishnav li li.sfhover ul, #suckerfishnav li li li.sfhover ul, #suckerfishnav li li li li.sfhover ul {
left:auto;
background:#000000;
}
#suckerfishnav li:hover, #suckerfishnav li.sfhover {
background:#9f0b0b;
}

teedoff
07-25-2011, 03:57 PM
What browser is this laptop using? Again, it seems to be working fine for me in IE8 and FF 3.6.

Here is a screenshot of what I get:

irishpeck
07-25-2011, 04:15 PM
Thats just the thing teed i cant figure out why its happening. Ive a Macbook Pro and im testing it in Safari, Opera and Firefox on it and it looks the exact same in all of them i cant figure out what the problem is with it. Can you see anything wrong with the code cause i cant see anything that would cause it not to work in it. I dont actually know what version of IE he is using as i dont have the laptop here. Although i do have a pc in work that is having the same problem and its running IE 7.0.5730.13 (128bit) does this have anything to do with it?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum