...

View Full Version : White lines in Outlook 2007 html email



WillisTi
07-17-2011, 09:27 PM
Hi folks,

see screenshot here: http://bit.ly/fSPl3A

and code that relates to that area below:


<table width="100%" border="0" cellspacing="0" cellpadding="0">
<td valign="top" width="335"><img style="display:block" src="http://www.test.com/tangled/images/logo.jpg" width="335" height="241" alt="Disney Tangled"></td>

<tr>
<td valign="top" width="335">
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td valign="top" width="72" style="font-size:1px; line-height:1px;"><img style="display:block" src="http://www.test.com/tangled/images/text-mid-lt.jpg" width="72" height="318" alt=""></td>
<td valign="top" width="241" style="background:#00597e">
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td valign="top" style=" font-size:11px; line-height:15px; font-weight:bold; font-family:Verdana, Geneva, sans-serif; text-align:center; color:#fff; padding:15px 0 0 0;">lorem impsum dolar set omoar</td>

</tr>
<tr>
<td valign="top" style="font-size:11px; line-height:15px; font-weight:normal; font-family:Verdana, Geneva, sans-serif; text-align:center; color:#fff;">Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex ea commodo consequat.</td>
</tr>
</table>
</td>
<td valign="top" width="22" style="font-size:1px; line-height:1px;"><img style="display:block" src="http://www.test.com/tangled/images/text-mid-rt.jpg" width="22" height="318" alt=""></td>
</tr>

</table>
</td>
</tr>
<tr>
<td valign="top" style="font-size:1px; line-height:1px;"><img style="display:block" src="http://www.test.com/tangled/images/text-bottom.jpg" width="335" height="50" alt=""></td>
</tr>
</table>

I've tested in Hotmail, Gmail and Outlook Express and it's perfect, this is the only issue left and I'm not sure what else I can try to fix it!

Any help would be much appreciated, cheers

jroeckle
07-21-2011, 11:53 PM
Looks like the parent table isn't constraining the child cells. It's trying to fill out whatever 100% width would be (thus adding the white spaces)

Try updating this:



<table width="100%" border="0" cellspacing="0" cellpadding="0">
<td valign="top" width="335"><img style="display:block" src="http://www.test.com/tangled/images/logo.jpg" width="335" height="241" alt="Disney Tangled"></td>


to this



<table width="335px" border="0" cellspacing="0" cellpadding="0">
<td valign="top" width="335"><img style="display:block" src="http://www.test.com/tangled/images/logo.jpg" width="335" height="241" alt="Disney Tangled"></td>


Hope that works!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum