View Full Version : changed server still shows old site on www.

06-13-2011, 12:48 PM
Something VERY odd is going on....

I changed hosting company and the DNS of the domain to point to the new server and hosting.

If I type in domain.com then it throws a 500 internal server error - if I remove the .htaccess the new site loads.

If I type in www.domain.com then it goes to the old hosting which is still online.

I am completely confused here and think it is due to the domain and .htaccess.

The .htaccess tells all URLs to be www. and I think that is the cause. If I remove that section of the .htaccess the problem is still not solved though...

ANy ideas what could be going on here?


07-09-2011, 09:37 AM
Your old hosting being shown when you visit the www. version of the domain name means that your DNS settings are either incorrect, cached or not fully propagated. It indicates essentially that the a record for www. is pointing to a different IP address to the non-subdomain hostname.

The 500 server error could be a number of things, it's going to be difficult to know what without knowing what was in the .htaccess file. The most likely cause is that you a.) were using mod_rewrite rules without mod_rewrite being enabled or b.) you had an infinite loop in your redirects.

07-09-2011, 07:56 PM
DNS can take up to 48 hours to propagate fully. Check your DNS settings, though. You likely have an A record for "www" that points explicitly to the old IP instead of using "@". Check your error log to see what is causing the 500 error.