...

View Full Version : Obsolete script element -- validation issue



Kevin_M_Schafer
05-02-2011, 11:19 AM
I have a validation issue with a weatherbug for my site. I get the following error:

"Line 16, Column 197: The language attribute on the script element is obsolete. Use the type attribute instead."

Here is the script:
<script language="javascript1.2" type="text/javascript" src="http://weatherreports.com/jscript.html?width=234&amp;height=60&amp;theme=white&amp;location=Fairfax%2C%20Minnesota%2055332&amp;units=f"></script>

Is anyone able to explain what the validation error is suggesting?

Any help would be greatly appreciated. Thanks.

AndrewGSW
05-02-2011, 11:38 AM
That is a very clear error message, and I can only repeat it: "the language attribute is obsolete, use the type attribute instead"


<script language="javascript1.2" type="text/javascript"

Kevin_M_Schafer
05-02-2011, 01:00 PM
I see, Andy. I wasn't deleting all of the previous attribute. I went all the way back, getting rid of the whole portion. Now it validates.

Thank you!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum