View Full Version : Bkgd image URL keeps changing by itself

04-20-2011, 12:26 AM
I am very new to CSS and HTML, but seem to be getting the hang of it. I have a website on which I've customized the CSS code in a premade template in order to change the background image, box images and menu buttons.

The host I'm using has an images folder which I've uploaded my image files to. The site then assigns a URL to each image I upload. I copy that URL and insert it into the CSS code in order to change the images on the site. It seemed to be working like a charm but shortly after i began modifying the site I noticed when I refreshed the pages I was working on, after a while all my image URL's are changing so the URL I inserted into the code is no longer valid!! Now I have to keep going and copying the new URL's and inserting them back into the code for my images to show up again! This is becoming quite annoying and I'm getting no support from my hosting service :mad:

Can anyone give me an idea why this might be happening?? This is my second site with this hosting service. I customized the CSS code on my first site as well and did not have this problem :confused:

ANY help would be much appreciated!!

Thanks in advance!

04-20-2011, 02:35 AM
How do you expect us to help you if you don't provide a link to your site?

04-20-2011, 11:35 PM
I did not know you needed the link to my site to help! As I'm sure you can see, I'm NEW to all this...


04-21-2011, 02:15 AM
The images show up fine for me. What images were you having problems with?

04-22-2011, 06:12 PM
The background on the site should be red glitter, there should be a granite texture behind the center box and the boxes on the right and left (wall of love and site news), and the menu buttons on the left side of the homepage should be a dark gray stone. When I view the site as it is currently, the background, the boxes and the menu are all a pink color :confused: Are you seeing the red glitter and stone??

04-22-2011, 06:20 PM
Okay I see in your CSS that you have the links to your images there. Have you tried contacting webnode yet? I'm sure they can probably tell you why the images are changing. Really though I would think about getting a real web host.

04-25-2011, 04:21 PM
I have tried contacting Webnode multiple times and honestly it's like pulling teeth trying to get help from them. Here was their response to my latest email to them....


if you want to change the pictures in the template, you need to download the template in "Layout options" - "Templates" there are three icons bellow each template thumbnail. Rightmost icon is for downloading the source code of the template.. In the img folder you can find the pictures and re-save them. Please keep the size of the pictures as defaulted.

Please note, that knowledge of HTML/XML, CSS and JavaScript is necessary for modifying the template. We don't offer technical support for custom templates. This is an expert feature that is left entirely up to the user.
Thank you for understanding.
Best regards,

Something I don't understand though, is I used a custom background on another site (discoverywatch.webnode.com) and the URL has never changed! Actually, I never had any troubles with the other site :confused:

I really need to use a free hosting service until we get a solid member base. Do you have any recommendations? I am very willing to check out others as I am VERY unimpressed and frustrated with Webnode :mad:

Thanks for your help btw :)