...

View Full Version : embedding swf files into HTML.



c.munro
04-09-2011, 11:16 PM
Hi,
I'm having trouble embedding my SWF files into my site.

I've added the file into the html code, but it appears to be hiding behind the background image?

A little help as to why this is happening?

cheers.



HTML
<body>



<div id="bg">
<img src="phone_bgrnd copy.png"/>
</div>

<h1>

<br/>
<A STYLE="text-decoration:none" href="Homepage_makedo.html">home</a>
<br/>
<a href="make_page.html";> Make</a>
<br/>community
<br/>About
<br/>Join

</h1>

<h2>
<b>08/11</b> Set the date in your diary, 07.08.11<br/>
We would like to put sustainable thinking into practice for <br/>
each individual, through the means of an App.<br/>
Think of it as a ration book for the office. We would like you<br/>
to record the amount of useage for each activity on the app<br />
throughout the day. Make do will then calculate your<br/>
Carbon Footprint. You can compare statistics throughout the office <br/>
or compare statistics with other Make do members!<br/>
</h2>



<div id='mov'>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="410" height="278" id="FlashID" title="movie">
<param name="movie" value="iphone_img/app.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="iphone_img/app.swf" width="410" height="278">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</div>
</body>
</html>


CSS
#bg {
position:fixed;
top:-50%;
left:-50%;
width:200%;
height:200%;
}


#bg img {
position:absolute;
top:0;
left:0;
right:0;
bottom:0;
margin:auto;
min-width:50%;
min-height:50%;
z-index:1;
}
mov {
position:absolute
top:34%;
left:56%;
z-index:3
}


h2 {

position:absolute;
top: 78%;
left: 38%;
font: 11px/1.5 'Gotham rounded';
color:#E9E3E9;
z-index:5;

}

h1 {

position:absolute;
top: -2%;
left: 30%;
font: 14px/1.5 'Gotham rounded';
color:#E9E3E9;
z-index:10;

}

abduraooft
04-10-2011, 02:08 PM
<param name="wmode" value="opaque" /> Try changing them to

<param name="wmode" value="transparent" />

_Aerospace_Eng_
04-10-2011, 04:09 PM
Your CSS is wrong too. This

mov {
position:absolute
top:34%;
left:56%;
z-index:3
}
should be

#mov {
position:absolute
top:34%;
left:56%;
z-index:3
}



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum