...

View Full Version : Trouble with links



SHEPME
04-08-2011, 03:26 AM
Good Day:
I am having trouble with the following code for my website. I have created a box called "header" that I placed my inline navagation links in.
I want the color of the link a yellow color and when the user rolls the mouse over the link it turns white. Everything works great unitill I added an additional box below that I was going to add either some text of pictures (not sure). When I roll my mouse over that box, the last link (the one that says "Reserve your vacation") turns white even though my mouse is nowhere near the link. I have tried everything. PLEASE help. I have copied my code below. Copy and paste the code and you will see what I am talking about.


<html>
<title>BEST WESTERN, MIAMI BEACH, FLORIDA</title>
<style type="text/css">
Body {margin-left: 0px; margin-right: 0px; margin-top: 0px; margin-bottom 0px;
background-color:white;}

#header {border:1px solid; margin-left:10px; margin-right:10px; height:90px;background-color:#045FB4;}
#headerb{border:1px solid; margin-left:10px; margin-right:10px; height:10px;background-color:#F9EE54;}
#headerc{border:1px solid; margin-left:10px; margin-right:10px; height:10px;background-color:#2d1c9b;}
#navigation{border:3px solid #2d1c9b; margin-top:30px; margin-left:0px; margin-right:630px; height:0px;}




<!-- Navigation Menu CSS Below -->


#navlist{
margin:0px;
padding:0px;
test-align:center;}

#navlist li{
list-style:none;
display:inline;}

#navlist li a{
color:#F9EE54;
background-color:#2d1c9b;
padding: .2em 1em;
test-decoration:none;}

#navlist li a:hover{
color:#ffffff;}

.active{
border:0px solid;
color:#F9EE54;
font-weight:bold;
padding: .3em 3em;}



</body>
</style>


<div id="headerb"></div>
<div id="headerc">


<ul id="navlist">
<li class="active"><a title="link:VIEW OUR SUITES "href="HTTP://WWW.CBS.COM">HOME
<li class="active"><a title="link:VIEW OUR SUITES "href="HTTP://WWW.CBS.COM">OUR LOCATION
<li class="active"><a title="link:VIEW OUR SUITES "href="HTTP://WWW.CBS.COM">OUR SUITS
<li class="active"><a title="link:VIEW OUR SUITES "href="HTTP://WWW.bestwestern.COM">RESERVE YOUR VACATION</ul></li></div>

<div id="navigation">

teedoff
04-08-2011, 04:37 AM
Is that your code in the order you have it in your document?

SHEPME
04-08-2011, 06:57 PM
Yes thats the way it is at this point while I am testing everything.
I appreciate you help however I found my error. I forgot the closing </a> tag at the end of my links.

teedoff
04-08-2011, 07:11 PM
You dont have any html page structure whatsoever.

Have a look at a standard html page structure here (http://www.w3schools.com/html/default.asp).

You should really go through that tutorial above and this will give you a basic understanding of how to create an html document.

SHEPME
04-08-2011, 07:28 PM
Teed, Thanks alot. That would be great. I will check it out after work. I just assumed that things went in order of how they are to appear on the screen and that as long as the end result worked?
I am new to all of this but really trying hard to learn html and css. I purchased Wendy Willards book on basic HTML and its been a great help. Could you reccomend other books dealing with CSS and web design etc..
Again thanks for your help.
shep



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum